summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-07-17 13:28:00 +0100
committerEmil Velikov <[email protected]>2015-09-09 12:48:39 +0100
commitda5e4559ee3b239d2483645ed54b35aa6628fbaf (patch)
tree6f840f6eaf751808373cd775e7abf8ec76873454 /src/glsl/Makefile.am
parent9e0594418d8fa47e19bfe57450198d3fa7d087a0 (diff)
glsl: automake: reuse $(NIR_GENERATED_FILES) where possible
Cc: 11.0 <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 9a7f33d7134..831849859ac 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -226,11 +226,7 @@ BUILT_SOURCES = \
glsl_lexer.cpp \
glcpp/glcpp-parse.c \
glcpp/glcpp-lex.c \
- nir/nir_builder_opcodes.h \
- nir/nir_constant_expressions.c \
- nir/nir_opcodes.c \
- nir/nir_opcodes.h \
- nir/nir_opt_algebraic.c
+ $(NIR_GENERATED_FILES)
CLEANFILES = \
glcpp/glcpp-parse.h \
glsl_parser.h \