summaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-07-17 13:30:51 +0100
committerEmil Velikov <[email protected]>2015-09-09 12:48:43 +0100
commita3b05e04921a4fcc05cfc994e415e3ceb39fd184 (patch)
treeaaa1c39931bb2a94a39284e957793c01479ad77b /src/glsl/Makefile.am
parentda5e4559ee3b239d2483645ed54b35aa6628fbaf (diff)
glsl: build: use makefile.sources variables when possible
Rather than folding one variable within the other only to unwrap them, just use the ones we need. v2: bring back LOCAL_PATH prefix for nir_constant_expressions,h Cc: 11.0 <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]> (v1)
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 831849859ac..7dfd60404ee 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -140,13 +140,16 @@ libglsl_la_SOURCES = \
glsl_parser.cpp \
glsl_parser.h \
$(LIBGLSL_FILES) \
- $(NIR_FILES)
+ $(NIR_FILES) \
+ $(NIR_GENERATED_FILES)
+
libnir_la_SOURCES = \
glsl_types.cpp \
builtin_types.cpp \
glsl_symbol_table.cpp \
- $(NIR_FILES)
+ $(NIR_FILES) \
+ $(NIR_GENERATED_FILES)
glsl_compiler_SOURCES = \
$(GLSL_COMPILER_CXX_FILES)