summaryrefslogtreecommitdiffstats
path: root/src/gbm/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-10-24 17:14:20 +0100
committerEmil Velikov <[email protected]>2017-11-08 14:40:12 +0000
commitc7b65c330fd6ede0c82d3e2f2907e5a3ae864788 (patch)
treea563f7802c55b05a5ab6efe1528ad0e29e959300 /src/gbm/Makefile.am
parentba414dba4f1bf354cc9494fd76e3e28b489f13a1 (diff)
wayland-drm: static inline wayland_drm_buffer_get
The function is effectively a direct function call into libwayland-server.so. Thus GBM no longer depends on the wayland-drm static library, making the build more straight forward. And the resulting binary is a bit smaller. Note: we need to move struct wayland_drm_callbacks further up, otherwise we'll get an error since the type is incomplete. v2: Rebase, beef-up commit message, update meson, move struct wayland_drm_callbacks. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Daniel Stone <[email protected]> (v1) Reviewed-by: Eric Engestrom <[email protected]> # meson bit only Acked-by: Eric Engestrom <[email protected]> # for the rest Reviewed-by: Dylan Baker <[email protected]> # meson
Diffstat (limited to 'src/gbm/Makefile.am')
-rw-r--r--src/gbm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gbm/Makefile.am b/src/gbm/Makefile.am
index 05d861ff999..682c4281f4c 100644
--- a/src/gbm/Makefile.am
+++ b/src/gbm/Makefile.am
@@ -34,7 +34,7 @@ if HAVE_PLATFORM_WAYLAND
AM_CFLAGS += \
$(WAYLAND_SERVER_CFLAGS) \
-I$(top_srcdir)/src/egl/wayland/wayland-drm/
-libgbm_la_LIBADD += $(top_builddir)/src/egl/wayland/wayland-drm/libwayland-drm.la $(WAYLAND_SERVER_LIBS)
+libgbm_la_LIBADD += $(WAYLAND_SERVER_LIBS)
endif
if HAVE_DRI2