summaryrefslogtreecommitdiffstats
path: root/src/gbm/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-20 17:49:42 -0700
committerDylan Baker <[email protected]>2017-11-02 11:39:45 -0700
commita29869e8720b385d3692f6a74de2921412b2c8c1 (patch)
tree5e9dab02c13d28896ee151572d6b074ddb38295a /src/gbm/Makefile.am
parent10d869535cc704c6f787f6759951bb5c87969b29 (diff)
gbm: Don't traverse backwards for includes
This is just a bad idea and should be avoided. Instead, make the #include flat and fix the build systems to pass the proper -I flags v2: - add an inc_wayland_drm instead passing a path to include_directories (Emil) - update commit message (Emil) Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Daniel Stone <[email protected]> (v1) Reviewed-by: Eric Engestrom <[email protected]> (v1)
Diffstat (limited to 'src/gbm/Makefile.am')
-rw-r--r--src/gbm/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/gbm/Makefile.am b/src/gbm/Makefile.am
index 805208a3ca9..05d861ff999 100644
--- a/src/gbm/Makefile.am
+++ b/src/gbm/Makefile.am
@@ -31,7 +31,9 @@ libgbm_la_LIBADD = \
$(DLOPEN_LIBS)
if HAVE_PLATFORM_WAYLAND
-AM_CFLAGS += $(WAYLAND_SERVER_CFLAGS)
+AM_CFLAGS += \
+ $(WAYLAND_SERVER_CFLAGS) \
+ -I$(top_srcdir)/src/egl/wayland/wayland-drm/
libgbm_la_LIBADD += $(top_builddir)/src/egl/wayland/wayland-drm/libwayland-drm.la $(WAYLAND_SERVER_LIBS)
endif