summaryrefslogtreecommitdiffstats
path: root/src/gbm/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-06-19 19:22:38 +0100
committerEmil Velikov <[email protected]>2015-06-23 17:08:05 +0100
commita0dc6b7824d3b9095919e29393a379ea7f9c1318 (patch)
tree676d80cd450badd1dab06536cc49fcab30b00624 /src/gbm/Makefile.am
parent828f13330c9384f2b55c8b0f962d93a74ecd0601 (diff)
gbm: do not (over)link against libglapi.so
The whole of GBM does not rely on even a single symbol from the GL dispatch library, unsuprisingly. The only need for it comes from the unresolved symbols in the DRI modules, which are now correctly handled with Frank's commit. Cc: "10.5 10.6" <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gbm/Makefile.am')
-rw-r--r--src/gbm/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/gbm/Makefile.am b/src/gbm/Makefile.am
index dbd4f833867..918fdf7d6ad 100644
--- a/src/gbm/Makefile.am
+++ b/src/gbm/Makefile.am
@@ -52,7 +52,8 @@ libgbm_dri_la_CFLAGS = \
$(LIBDRM_CFLAGS)
libgbm_la_LIBADD += \
- libgbm_dri.la $(top_builddir)/src/mapi/shared-glapi/libglapi.la $(LIBDRM_LIBS)
+ libgbm_dri.la \
+ $(LIBDRM_LIBS)
endif
TESTS = gbm-symbols-check