summaryrefslogtreecommitdiffstats
path: root/src/gallium/winsys/Makefile.am
diff options
context:
space:
mode:
authorGiovanni Campagna <[email protected]>2014-07-23 19:37:31 +0100
committerEmil Velikov <[email protected]>2014-07-30 16:33:09 +0100
commit3b176c441b7ddc5f7d2f891da3f76cf3c1814ce1 (patch)
treea99421810f0150b9759363fb56910a160d10ad97 /src/gallium/winsys/Makefile.am
parent8430af5ebe1ee8119e14ae8fe00ec98fda40c57f (diff)
gallium: Add a dumb drm/kms winsys backed swrast provider
Add a new winsys and target that can be used with a dri2 state tracker and loader instead of drisw. This allows to use gbm as a dri2/image loader and avoid the extra copy from the backbuffer to the shadow frontbuffer. The new driver is called "kms_swrast", and is loaded by gbm as a fallback, because it is only useful with the gbm platform (as no buffer sharing is possible) To force select the driver set the environment variable GBM_ALWAYS_SOFTWARE [Emil Velikov] - Rebase on top of gallium megadriver. - s/text/test/ in configure.ac (Spotted by Andreas Pokorny). - Add scons support for winsys/sw/kms-dri and fix the build. - Provide separate DriverAPI, due to different InitScreen hook. Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/winsys/Makefile.am')
-rw-r--r--src/gallium/winsys/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/gallium/winsys/Makefile.am b/src/gallium/winsys/Makefile.am
index 7c4e5ad564c..4c01afdee20 100644
--- a/src/gallium/winsys/Makefile.am
+++ b/src/gallium/winsys/Makefile.am
@@ -30,6 +30,10 @@ if HAVE_DRISW
SUBDIRS += sw/dri
endif
+if HAVE_DRI2
+SUBDIRS += sw/kms-dri
+endif
+
if HAVE_EGL_PLATFORM_FBDEV
SUBDIRS += sw/fbdev
endif