summaryrefslogtreecommitdiffstats
path: root/src/gallium/tests/unit/Makefile.am
diff options
context:
space:
mode:
authorAndreas Boll <[email protected]>2012-11-27 19:18:25 +0100
committerAndreas Boll <[email protected]>2013-01-10 22:01:30 +0100
commitcb4d5021c66d3067d592ce07d77373cf956c8459 (patch)
tree23c7612575cf272d36d1682043585a85f9472814 /src/gallium/tests/unit/Makefile.am
parent59088a2c2cf2b2a8bfaf19ae6440ea827c891d9d (diff)
gallium/tests/unit: Convert to automake
Diffstat (limited to 'src/gallium/tests/unit/Makefile.am')
-rw-r--r--src/gallium/tests/unit/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/gallium/tests/unit/Makefile.am b/src/gallium/tests/unit/Makefile.am
new file mode 100644
index 00000000000..c157cc026da
--- /dev/null
+++ b/src/gallium/tests/unit/Makefile.am
@@ -0,0 +1,34 @@
+# TODO: wire up some useful tests to make check
+
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ $(GALLIUM_CFLAGS)
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/gallium/drivers \
+ -I$(top_srcdir)/src/gallium/winsys
+
+LDADD = \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
+ $(top_builddir)/src/gallium/winsys/sw/null/libws_null.la \
+ $(top_builddir)/src/gallium/drivers/softpipe/libsoftpipe.la \
+ $(DLOPEN_LIBS) \
+ $(PTHREAD_LIBS) \
+ -lm
+
+noinst_PROGRAMS = pipe_barrier_test u_cache_test u_half_test \
+ u_format_test u_format_compatible_test translate_test
+
+pipe_barrier_test_SOURCES = pipe_barrier_test.c
+
+u_cache_test_SOURCES = u_cache_test.c
+
+u_half_test_SOURCES = u_half_test.c
+
+u_format_test_SOURCES = u_format_test.c
+
+u_format_compatible_test_SOURCES = u_format_compatible_test.c
+
+translate_test_SOURCES = translate_test.c