summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/xvmc/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-01-17 10:26:58 -0800
committerDylan Baker <[email protected]>2018-02-15 10:35:51 -0800
commit7023b373ec76a2ea25b1bd0a7501276de9007047 (patch)
treeb975ffd2597cae5a512ad77ec96d2fb90a160e25 /src/gallium/targets/xvmc/meson.build
parent424e654cb02182c00d1b76c512a8fe17af281e4b (diff)
meson: link dri3 xcb libs into vlwinsys instead of into each target
This makes the dependencies easier to manage, since each media target doesn't need to worry about linking to half a dozen libraries. Fixes: b1b65397d0c4978e3 ("meson: Build gallium auxiliary") Signed-off-by: Dylan Baker <[email protected]> Acked-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/targets/xvmc/meson.build')
-rw-r--r--src/gallium/targets/xvmc/meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/gallium/targets/xvmc/meson.build b/src/gallium/targets/xvmc/meson.build
index 48759de910f..07d6c729c9a 100644
--- a/src/gallium/targets/xvmc/meson.build
+++ b/src/gallium/targets/xvmc/meson.build
@@ -44,10 +44,7 @@ libxvmc_gallium = shared_library(
libxvmc_st, libgalliumvlwinsys, libgalliumvl, libgallium, libmesa_util,
libpipe_loader_static, libws_null, libwsw,
],
- dependencies : [
- dep_xcb, dep_x11_xcb, dep_xcb_dri2, dep_xcb_dri3, dep_libdrm, dep_thread,
- driver_r600, driver_nouveau,
- ],
+ dependencies : [dep_thread, driver_r600, driver_nouveau],
link_depends : xvmc_link_depends,
)