aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/xa-vmwgfx/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-07 15:24:24 -0700
committerAndreas Boll <[email protected]>2013-01-10 22:01:11 +0100
commitd53901c67c7df914fbc5279f25d0e725c479bab0 (patch)
tree2f56a226d30f090cf4e807ccf910dfd41fc72ebf /src/gallium/targets/xa-vmwgfx/Makefile.am
parentaf6a2e4f820631e3bb64ad726ad774af45f1759d (diff)
targets/xa-vmwgfx: Convert to automake
v2: Andreas Boll <[email protected]> - Provide compatibility with scripts for the old Mesa build system
Diffstat (limited to 'src/gallium/targets/xa-vmwgfx/Makefile.am')
-rw-r--r--src/gallium/targets/xa-vmwgfx/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/src/gallium/targets/xa-vmwgfx/Makefile.am b/src/gallium/targets/xa-vmwgfx/Makefile.am
new file mode 100644
index 00000000000..01cff4b535e
--- /dev/null
+++ b/src/gallium/targets/xa-vmwgfx/Makefile.am
@@ -0,0 +1,59 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ -Wall -pedantic \
+ $(GALLIUM_CFLAGS) \
+ $(XORG_CFLAGS)
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/gallium/drivers \
+ -I$(top_srcdir)/src/gallium/winsys
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xatracker.pc
+
+lib_LTLIBRARIES = libxatracker.la
+
+libxatracker_la_SOURCES = vmw_target.c
+
+libxatracker_la_LDFLAGS = -version-number $(XA_MAJOR):$(XA_MINOR):$(XA_TINY)
+
+libxatracker_la_LIBADD = \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(top_builddir)/src/gallium/state_trackers/xa/libxatracker.la \
+ $(top_builddir)/src/gallium/winsys/svga/drm/libsvgadrm.la \
+ $(top_builddir)/src/gallium/drivers/svga/libsvga.la \
+ $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
+ $(top_builddir)/src/gallium/drivers/rbug/librbug.la
+
+if HAVE_MESA_LLVM
+libxatracker_la_LDFLAGS += $(LLVM_LDFLAGS)
+libxatracker_la_LIBADD += $(LLVM_LIBS)
+endif
+
+# Provide compatibility with scripts for the old Mesa build system for
+# a while by putting a link to the driver into /lib of the build tree.
+all-local: libxatracker.la
+ $(MKDIR_P) $(top_builddir)/$(LIB_DIR)/gallium
+ ln -f .libs/libxatracker.so* $(top_builddir)/$(LIB_DIR)/gallium/