summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/vdpau-r300/Makefile.am
diff options
context:
space:
mode:
authorChristian König <[email protected]>2013-09-25 11:49:49 +0200
committerChristian König <[email protected]>2013-09-25 19:41:03 +0200
commit533e9a04b4de9f9a10b6ccb0e4d4e3eb66cdd8e7 (patch)
tree093ca168fd73eea08f3a7e88bdfd348298863fb5 /src/gallium/targets/vdpau-r300/Makefile.am
parent1c57d9a6c6f967c37acde9ec11855b72a33d95dd (diff)
build/r300: group build target in common subdir
Allows us to share more code between different targets. Signed-off-by: Christian König <[email protected]> Acked-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/gallium/targets/vdpau-r300/Makefile.am')
-rw-r--r--src/gallium/targets/vdpau-r300/Makefile.am70
1 files changed, 0 insertions, 70 deletions
diff --git a/src/gallium/targets/vdpau-r300/Makefile.am b/src/gallium/targets/vdpau-r300/Makefile.am
deleted file mode 100644
index 350f6f887b3..00000000000
--- a/src/gallium/targets/vdpau-r300/Makefile.am
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright © 2012 Intel Corporation
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice (including the next
-# paragraph) shall be included in all copies or substantial portions of the
-# Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
-# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
-# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-# DEALINGS IN THE SOFTWARE.
-
-include $(top_srcdir)/src/gallium/Automake.inc
-
-AM_CFLAGS = \
- $(GALLIUM_CFLAGS) \
- $(PTHREAD_CFLAGS) \
- $(LIBDRM_CFLAGS)
-AM_CPPFLAGS = \
- -I$(top_srcdir)/src/gallium/drivers \
- -I$(top_srcdir)/src/gallium/winsys
-
-vdpaudir = $(VDPAU_LIB_INSTALL_DIR)
-vdpau_LTLIBRARIES = libvdpau_r300.la
-
-nodist_EXTRA_libvdpau_r300_la_SOURCES = dummy.cpp
-libvdpau_r300_la_SOURCES = \
- target.c \
- $(top_srcdir)/src/gallium/auxiliary/vl/vl_winsys_dri.c
-
-libvdpau_r300_la_LDFLAGS = \
- -module \
- -version-number $(VDPAU_MAJOR):$(VDPAU_MINOR) \
- -shared \
- -no-undefined
-
-libvdpau_r300_la_LIBADD = \
- $(top_builddir)/src/gallium/auxiliary/libgallium.la \
- $(top_builddir)/src/gallium/drivers/r300/libr300-helper.la \
- $(top_builddir)/src/gallium/drivers/r300/libr300.la \
- $(top_builddir)/src/gallium/state_trackers/vdpau/libvdpautracker.la \
- $(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la \
- $(top_builddir)/src/gallium/drivers/rbug/librbug.la \
- $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
- $(top_builddir)/src/gallium/drivers/galahad/libgalahad.la \
- $(GALLIUM_DRI_LIB_DEPS) \
- $(VDPAU_LIBS) \
- $(LIBDRM_LIBS) \
- $(RADEON_LIBS)
-
-if HAVE_MESA_LLVM
-libvdpau_r300_la_LDFLAGS += $(LLVM_LDFLAGS)
-libvdpau_r300_la_LIBADD += $(LLVM_LIBS)
-endif
-
-# Provide compatibility with scripts for the old Mesa build system for
-# a while by putting a link to the driver into /lib of the build tree.
-all-local: libvdpau_r300.la
- $(MKDIR_P) $(top_builddir)/$(LIB_DIR)/gallium
- ln -f .libs/libvdpau_r300.so* $(top_builddir)/$(LIB_DIR)/gallium/