summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/radeonsi/vdpau/Makefile.am
diff options
context:
space:
mode:
authorChristian König <[email protected]>2013-09-25 12:28:09 +0200
committerChristian König <[email protected]>2013-09-25 19:41:27 +0200
commitf6e2aa0e12e4ce91dc6f8ac5140d6e1f511ea468 (patch)
tree4f56399d2bc73f95c671c8fbe0cfaf00b2506c23 /src/gallium/targets/radeonsi/vdpau/Makefile.am
parent015853b56872deea493b25248d760ee4eda198e9 (diff)
build/radeonsi: group all targets in common subdir
Allows us to share more code between different targets. Signed-off-by: Christian König <[email protected]> Acked-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/gallium/targets/radeonsi/vdpau/Makefile.am')
-rw-r--r--src/gallium/targets/radeonsi/vdpau/Makefile.am69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/gallium/targets/radeonsi/vdpau/Makefile.am b/src/gallium/targets/radeonsi/vdpau/Makefile.am
new file mode 100644
index 00000000000..bda88e69997
--- /dev/null
+++ b/src/gallium/targets/radeonsi/vdpau/Makefile.am
@@ -0,0 +1,69 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(PTHREAD_CFLAGS) \
+ $(LIBDRM_CFLAGS)
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/gallium/drivers \
+ -I$(top_srcdir)/src/gallium/winsys
+
+vdpaudir = $(VDPAU_LIB_INSTALL_DIR)
+vdpau_LTLIBRARIES = libvdpau_radeonsi.la
+
+nodist_EXTRA_libvdpau_radeonsi_la_SOURCES = dummy.cpp
+libvdpau_radeonsi_la_SOURCES = \
+ ../drm_target.c \
+ $(top_srcdir)/src/gallium/auxiliary/vl/vl_winsys_dri.c
+
+libvdpau_radeonsi_la_LDFLAGS = \
+ -module \
+ -version-number $(VDPAU_MAJOR):$(VDPAU_MINOR) \
+ -shared \
+ -no-undefined
+
+libvdpau_radeonsi_la_LIBADD = \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(top_builddir)/src/gallium/drivers/radeonsi/libradeonsi.la \
+ $(top_builddir)/src/gallium/state_trackers/vdpau/libvdpautracker.la \
+ $(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la \
+ $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
+ $(top_builddir)/src/gallium/drivers/rbug/librbug.la \
+ $(top_builddir)/src/gallium/drivers/noop/libnoop.la \
+ $(GALLIUM_DRI_LIB_DEPS) \
+ $(VDPAU_LIBS) \
+ $(LIBDRM_LIBS) \
+ $(RADEON_LIBS)
+
+if HAVE_MESA_LLVM
+libvdpau_radeonsi_la_LDFLAGS += $(LLVM_LDFLAGS)
+libvdpau_radeonsi_la_LIBADD += $(LLVM_LIBS)
+endif
+
+# Provide compatibility with scripts for the old Mesa build system for
+# a while by putting a link to the driver into /lib of the build tree.
+all-local: libvdpau_radeonsi.la
+ $(MKDIR_P) $(top_builddir)/$(LIB_DIR)/gallium
+ ln -f .libs/libvdpau_radeonsi.so* $(top_builddir)/$(LIB_DIR)/gallium/