summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/r600/xvmc/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-12 16:59:58 +0100
committerEmil Velikov <[email protected]>2014-06-22 23:06:07 +0100
commitdf71b39f5c5cef375ec1124e32b21cbb10acb0b2 (patch)
tree347ca0c16d544179d0b4317b57553f21a3bf0a36 /src/gallium/targets/r600/xvmc/Makefile.am
parentdc01ca44a796ab7cc5452913c495ba90ebb648b8 (diff)
targets/r600/xvmc: convert to static/shared pipe-drivers
The r600 equivalent of previous commit. v2: Correctly include the radeon winsys/radeon_common. Cc: Christian König <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Christian König <[email protected]> Tested-by: Thomas Helland <thomashelland90 at gmail.com>
Diffstat (limited to 'src/gallium/targets/r600/xvmc/Makefile.am')
-rw-r--r--src/gallium/targets/r600/xvmc/Makefile.am46
1 files changed, 0 insertions, 46 deletions
diff --git a/src/gallium/targets/r600/xvmc/Makefile.am b/src/gallium/targets/r600/xvmc/Makefile.am
deleted file mode 100644
index f2aec1a7122..00000000000
--- a/src/gallium/targets/r600/xvmc/Makefile.am
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright © 2012 Intel Corporation
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice (including the next
-# paragraph) shall be included in all copies or substantial portions of the
-# Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
-# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
-# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-# DEALINGS IN THE SOFTWARE.
-
-include $(top_srcdir)/src/gallium/Automake.inc
-
-AM_CPPFLAGS = \
- -DSPLIT_TARGETS=1
-AM_CFLAGS = \
- $(GALLIUM_VIDEO_CFLAGS)
-
-xvmcdir = $(XVMC_LIB_INSTALL_DIR)
-xvmc_LTLIBRARIES = libXvMCr600.la
-
-nodist_EXTRA_libXvMCr600_la_SOURCES = dummy.cpp
-libXvMCr600_la_SOURCES = \
- drm_target.c \
- $(top_srcdir)/src/gallium/auxiliary/vl/vl_winsys_dri.c
-
-libXvMCr600_la_LDFLAGS = \
- $(GALLIUM_XVMC_LINKER_FLAGS)
-
-libXvMCr600_la_LIBADD = \
- $(top_builddir)/src/gallium/drivers/radeon/libradeon.la \
- $(top_builddir)/src/gallium/drivers/r600/libr600.la \
- $(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la \
- $(GALLIUM_XVMC_LIB_DEPS) \
- $(RADEON_LIBS)