summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/r600/vdpau/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-03-11 15:24:07 +0000
committerEmil Velikov <[email protected]>2014-03-31 12:26:47 +0100
commit0484b8446a02a4b77d5a1dab89f6e0b8af831027 (patch)
tree044c399c8d86c9e59e138785a2b4a2646064d879 /src/gallium/targets/r600/vdpau/Makefile.am
parent2d9c33009a62b704e64b49b87ed1cee9c8dcb12b (diff)
gallium/targets: explicitly include a dummy.cpp and remove all the LINK mayhem
Explicitly setting the linker variable was required for old and broken build toolchains. At this point this should no longer be needed, and setting the sources lists will trigger generation of the correct LINK variables. Explicitly include dummy.cpp to use g++ to link the static library which in most cases is based upon C++ code. v2: Reword commit message. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/gallium/targets/r600/vdpau/Makefile.am')
-rw-r--r--src/gallium/targets/r600/vdpau/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/gallium/targets/r600/vdpau/Makefile.am b/src/gallium/targets/r600/vdpau/Makefile.am
index 1ff35e0d296..455d90f795b 100644
--- a/src/gallium/targets/r600/vdpau/Makefile.am
+++ b/src/gallium/targets/r600/vdpau/Makefile.am
@@ -30,6 +30,7 @@ AM_CFLAGS = \
vdpaudir = $(VDPAU_LIB_INSTALL_DIR)
vdpau_LTLIBRARIES = libvdpau_r600.la
+nodist_EXTRA_libvdpau_r600_la_SOURCES = dummy.cpp
libvdpau_r600_la_SOURCES = \
drm_target.c \
$(top_srcdir)/src/gallium/auxiliary/vl/vl_winsys_dri.c
@@ -44,8 +45,4 @@ libvdpau_r600_la_LIBADD = \
$(GALLIUM_VDPAU_LIB_DEPS) \
$(RADEON_LIBS)
-libvdpau_r600_la_LINK = $(CXXLINK) $(libvdpau_r600_la_LDFLAGS)
-# Mention a dummy pure C++ file to trigger generation of the $(LINK) variable
-nodist_EXTRA_libvdpau_r600_la_SOURCES = dummy-cpp.cpp
-
include $(top_srcdir)/install-gallium-links.mk