summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/r600/dri/Makefile.am
diff options
context:
space:
mode:
authorMaarten Lankhorst <[email protected]>2014-03-06 15:20:56 +0100
committerMaarten Lankhorst <[email protected]>2014-03-10 17:08:19 +0100
commit8c136b53b79e90b9e8f30f891b8bef112fee375d (patch)
treeead859a9735573cb4df2913a04da7a12e9f0652e /src/gallium/targets/r600/dri/Makefile.am
parent952fda4d3feca9b676a12d011523feaaf5836086 (diff)
fix vdpau interop when using -Bsymbolic-functions in ldflags
Explicitly add radeon_drm_winsys_create and nouveau_drm_screen_create to the dynamic list. This will ensure vdpau interop still works even when the user links with -Bsymbolic-functions in hardened builds. Signed-off-by: Maarten Lankhorst <[email protected]> Tested-by: Rachel Greenham <[email protected]> Reported-by: Peter Frühberger <[email protected]> Reviewed-by: Christian König <[email protected]>
Diffstat (limited to 'src/gallium/targets/r600/dri/Makefile.am')
-rw-r--r--src/gallium/targets/r600/dri/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/gallium/targets/r600/dri/Makefile.am b/src/gallium/targets/r600/dri/Makefile.am
index 1f13b803e0b..f0a1b7bdd23 100644
--- a/src/gallium/targets/r600/dri/Makefile.am
+++ b/src/gallium/targets/r600/dri/Makefile.am
@@ -36,7 +36,9 @@ dri_LTLIBRARIES = r600_dri.la
r600_dri_la_SOURCES = \
drm_target.c
-r600_dri_la_LDFLAGS = $(GALLIUM_DRI_LINKER_FLAGS)
+r600_dri_la_LDFLAGS = \
+ $(GALLIUM_DRI_LINKER_FLAGS) \
+ -Wl,--dynamic-list=$(srcdir)/../../r300/dri/radeon.dyn
r600_dri_la_LIBADD = \
$(top_builddir)/src/mesa/drivers/dri/common/libdricommon.la \