summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/pipe-loader/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-05-10 14:35:08 +0100
committerEmil Velikov <[email protected]>2014-05-15 17:32:30 +0100
commitd812c745829be2155fdd0d10e4a12606c2a10826 (patch)
tree21177e54bb2eb6676774ca478b153b80276f6014 /src/gallium/targets/pipe-loader/Makefile.am
parent6fcc0b0ba5b5a554682b782ee5f7930d7aabbe8e (diff)
gallium/radeon: link in libradeon.la at target level
It makes more sense to link the core and common parts of the driver as the target is build. Additionally this will help us drop duplicating symbols for targets that static link mulitple pipe-drivers. Only egl-static needs that currently with more to come. To simplify things a bit add HAVE_GALLIUM_RADEON_COMMON variable. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/targets/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/targets/pipe-loader/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/gallium/targets/pipe-loader/Makefile.am b/src/gallium/targets/pipe-loader/Makefile.am
index a1c7d251b5a..328069416d1 100644
--- a/src/gallium/targets/pipe-loader/Makefile.am
+++ b/src/gallium/targets/pipe-loader/Makefile.am
@@ -107,6 +107,7 @@ nodist_EXTRA_pipe_r600_la_SOURCES = dummy.cpp
pipe_r600_la_LIBADD = \
$(PIPE_LIBS) \
$(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la \
+ $(top_builddir)/src/gallium/drivers/radeon/libradeon.la \
$(top_builddir)/src/gallium/drivers/r600/libr600.la \
$(LIBDRM_LIBS) \
$(RADEON_LIBS)
@@ -121,6 +122,7 @@ nodist_EXTRA_pipe_radeonsi_la_SOURCES = dummy.cpp
pipe_radeonsi_la_LIBADD = \
$(PIPE_LIBS) \
$(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la \
+ $(top_builddir)/src/gallium/drivers/radeon/libradeon.la \
$(top_builddir)/src/gallium/drivers/radeonsi/libradeonsi.la \
$(LIBDRM_LIBS) \
$(RADEON_LIBS)