summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/pipe-loader/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-04-05 18:04:18 +0100
committerEmil Velikov <[email protected]>2014-05-02 21:48:27 +0100
commitce6c17c0833032e91a2d1b34f9eb80c738a854a2 (patch)
treebbcb7ad64b593741d2210014b8f5fad73f6628b2 /src/gallium/targets/pipe-loader/Makefile.am
parentf743670b9a10ab296a5e90b866d1c766d44cf98d (diff)
targets/pipe-loader: cleanup version-script
Drop the version/name tag from the script as it was never meant to be there. Add swrast_create_screen as it is used when loading swrast. Rename the file to pipe.sym. v2: Rebase on top of the LD_NO_UNDEFINED changes. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Francisco Jerez <[email protected]>
Diffstat (limited to 'src/gallium/targets/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/targets/pipe-loader/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gallium/targets/pipe-loader/Makefile.am b/src/gallium/targets/pipe-loader/Makefile.am
index 6a5b38066cb..a1c7d251b5a 100644
--- a/src/gallium/targets/pipe-loader/Makefile.am
+++ b/src/gallium/targets/pipe-loader/Makefile.am
@@ -47,9 +47,9 @@ AM_LDFLAGS = \
-module \
-no-undefined \
-avoid-version \
+ -Wl,--version-script=$(top_srcdir)/src/gallium/targets/pipe-loader/pipe.sym \
$(GC_SECTIONS) \
- $(LD_NO_UNDEFINED) \
- -Wl,--version-script=$(top_srcdir)/src/gallium/targets/pipe-loader/pipe.link
+ $(LD_NO_UNDEFINED)
if HAVE_MESA_LLVM
PIPE_LIBS += $(LLVM_LIBS)