summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/pipe-loader/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-03-13 05:44:33 +0000
committerEmil Velikov <[email protected]>2014-03-31 13:09:23 +0100
commitd187a150d45cbf5bd3476eab49be5057382c2c86 (patch)
tree21d55b22990122812b5875f31cc1d09966fedc39 /src/gallium/targets/pipe-loader/Makefile.am
parent902dc61f886c0d719ce25894bbc8032ede0f409b (diff)
automake: add -Wl,--no-undefined to all libraries
... apart from the dri drivers. With this final change we can build mesa without fear that the resulting libraries will have unresolved symbols. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/gallium/targets/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/targets/pipe-loader/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/targets/pipe-loader/Makefile.am b/src/gallium/targets/pipe-loader/Makefile.am
index 6e78a75b6d2..00823fe5bdd 100644
--- a/src/gallium/targets/pipe-loader/Makefile.am
+++ b/src/gallium/targets/pipe-loader/Makefile.am
@@ -49,6 +49,7 @@ AM_LDFLAGS = \
-module \
-no-undefined \
-avoid-version \
+ -Wl,--no-undefined \
-Wl,--version-script=$(top_srcdir)/src/gallium/targets/pipe-loader/pipe.link
if HAVE_MESA_LLVM