summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/opencl/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2019-04-08 12:44:17 -0700
committerDylan Baker <[email protected]>2019-04-15 13:44:29 -0700
commit95aefc94a941701616fda0776a3bd15710c8c151 (patch)
treebced9cf424ee7eb0cf753503eaace7cec4f62b50 /src/gallium/targets/opencl/Makefile.am
parentde0c97c8171f8a8183b94d8ac6997117c4671da8 (diff)
Delete autotools
Acked-by: Kenneth Graunke <[email protected]> Reviewed-by: Eric Anholt <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Acked-by: Marek Olšák <[email protected]> Acked-by: Jason Ekstrand <[email protected]> Acked-by: Bas Nieuwenhuizen <[email protected]> Acked-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/gallium/targets/opencl/Makefile.am')
-rw-r--r--src/gallium/targets/opencl/Makefile.am51
1 files changed, 0 insertions, 51 deletions
diff --git a/src/gallium/targets/opencl/Makefile.am b/src/gallium/targets/opencl/Makefile.am
deleted file mode 100644
index f0e1de7797c..00000000000
--- a/src/gallium/targets/opencl/Makefile.am
+++ /dev/null
@@ -1,51 +0,0 @@
-include $(top_srcdir)/src/gallium/Automake.inc
-
-lib_LTLIBRARIES = lib@[email protected]
-
-lib@OPENCL_LIBNAME@_la_LDFLAGS = \
- $(LLVM_LDFLAGS) \
- -no-undefined \
- -version-number @OPENCL_VERSION@:0 \
- $(GC_SECTIONS) \
- $(LD_NO_UNDEFINED)
-
-if HAVE_LD_VERSION_SCRIPT
-lib@OPENCL_LIBNAME@_la_LDFLAGS += \
- -Wl,--version-script=$(top_srcdir)/src/gallium/targets/opencl/opencl.sym
-endif
-
-lib@OPENCL_LIBNAME@_la_LIBADD = \
- $(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader_dynamic.la \
- $(top_builddir)/src/gallium/state_trackers/clover/libclover.la \
- $(top_builddir)/src/gallium/auxiliary/libgallium.la \
- $(top_builddir)/src/util/libmesautil.la \
- $(EXPAT_LIBS) \
- $(LIBELF_LIBS) \
- $(DLOPEN_LIBS) \
- -lclangCodeGen \
- -lclangFrontend \
- -lclangFrontendTool \
- -lclangDriver \
- -lclangSerialization \
- -lclangParse \
- -lclangSema \
- -lclangAnalysis \
- -lclangAST \
- -lclangEdit \
- -lclangLex \
- -lclangBasic \
- $(LLVM_LIBS) \
- $(PTHREAD_LIBS)
-
-nodist_EXTRA_lib@OPENCL_LIBNAME@_la_SOURCES = dummy.cpp
-lib@OPENCL_LIBNAME@_la_SOURCES =
-
-EXTRA_lib@OPENCL_LIBNAME@_la_DEPENDENCIES = opencl.sym
-EXTRA_DIST = mesa.icd opencl.sym meson.build
-
-if HAVE_CLOVER_ICD
-icddir = $(sysconfdir)/OpenCL/vendors/
-icd_DATA = mesa.icd
-endif
-
-include $(top_srcdir)/install-gallium-links.mk