summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/opencl/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2013-01-18 16:35:28 +0000
committerTom Stellard <[email protected]>2013-01-24 15:45:32 +0000
commit0261b4ecdb80973b3a00cbe6a9a77c6085ef3dff (patch)
treea54ae12db52255444037e969789e858d0b5bf6c0 /src/gallium/targets/opencl/Makefile.am
parentcf69a591e1ad16b590c9ae2eba0da6fa6c4fc741 (diff)
Revert "Revert "targets/opencl: Link against libgallium.la instead of libgallium.a""
This reverts commit 7824ab807050c03c6df01c44774914dcbef88248. Now that we force linking with LLVM shared libs when building clover, we can link against libgallium.la with no problems.
Diffstat (limited to 'src/gallium/targets/opencl/Makefile.am')
-rw-r--r--src/gallium/targets/opencl/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/gallium/targets/opencl/Makefile.am b/src/gallium/targets/opencl/Makefile.am
index be8ec12ceb7..c5c30030cad 100644
--- a/src/gallium/targets/opencl/Makefile.am
+++ b/src/gallium/targets/opencl/Makefile.am
@@ -6,11 +6,9 @@ libOpenCL_la_LDFLAGS = \
$(LLVM_LDFLAGS) \
-version-number 1:0
-# We are linking against libgallium.a rather than libgallium.la to work around
-# https://bugs.freedesktop.org/show_bug.cgi?id=59334
libOpenCL_la_LIBADD = \
$(top_builddir)/src/gallium/state_trackers/clover/libclover.la \
- $(top_builddir)/src/gallium/auxiliary/libgallium.a \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(GALLIUM_PIPE_LOADER_LIBS) $(LIBUDEV_LIBS) \
-ldl \
-lclangCodeGen \