aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/omx/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-07-22 14:50:15 +0100
committerEric Engestrom <[email protected]>2019-08-03 00:08:37 +0000
commitd2d85b950d78c553b2694cda9ef0cc7bf9a0f737 (patch)
treeafdd28e30b66064b8b540a6e9d6d0ecbe27a6678 /src/gallium/targets/omx/meson.build
parent8ddb38209d51c53d6e5792b04b97814dfce9bce6 (diff)
meson: replace libmesa_util with idep_mesautil
This automates the include_directories and dependencies tracking so that all users of libmesa_util don't need to add them manually. Next commit will remove the ones that were only added for that reason. Signed-off-by: Eric Engestrom <[email protected]> Acked-by: Eric Anholt <[email protected]> Tested-by: Vinson Lee <[email protected]>
Diffstat (limited to 'src/gallium/targets/omx/meson.build')
-rw-r--r--src/gallium/targets/omx/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gallium/targets/omx/meson.build b/src/gallium/targets/omx/meson.build
index 7772ae47bb5..0a748106b5c 100644
--- a/src/gallium/targets/omx/meson.build
+++ b/src/gallium/targets/omx/meson.build
@@ -41,11 +41,11 @@ libomx_gallium = shared_library(
],
link_whole : [libomx_st],
link_with : [
- libgalliumvlwinsys, libgalliumvl, libgallium, libmesa_util,
+ libgalliumvlwinsys, libgalliumvl, libgallium,
libpipe_loader_static, libws_null, libwsw, libswdri, libswkmsdri,
],
link_depends : omx_link_depends,
- dependencies : [dep_thread, driver_r600, driver_radeonsi, driver_nouveau],
+ dependencies : [dep_thread, idep_mesautil, driver_r600, driver_radeonsi, driver_nouveau],
install : true,
install_dir : omx_drivers_path,
)