aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/libgl-xlib/Makefile.am
diff options
context:
space:
mode:
authorTobias Droste <[email protected]>2016-11-19 02:39:04 +0100
committerEmil Velikov <[email protected]>2016-12-05 14:43:46 +0000
commit9d14a25bee0f1457a82f3e42b3baf3db1806faea (patch)
treeccec158b8362518d31d81d82ff96ef13a0ff9050 /src/gallium/targets/libgl-xlib/Makefile.am
parent19ff3975de6947bb8c6bfddff8e599c737f9185f (diff)
configure.ac: Move llvm_set_environment_variables higher.
This moves the function to get the LLVM environment variables higher in the file. It still needs to be below the "--enable-opencl" because it uses $enable_opencl. It can be called without condition now as it only throws errors if openCL is enabled. v5: HAVE_MESA_LLVM is only used for gallium. Rename it to HAVE_GALLIUM_LLVM. In order to only link LLVM when it is needed, HAVE_GALLIUM_LLVM is only set if "$enable-gallium-llvm" is yes. Signed-off-by: Tobias Droste <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/targets/libgl-xlib/Makefile.am')
-rw-r--r--src/gallium/targets/libgl-xlib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gallium/targets/libgl-xlib/Makefile.am b/src/gallium/targets/libgl-xlib/Makefile.am
index 3f1382e2848..6f966c3aebe 100644
--- a/src/gallium/targets/libgl-xlib/Makefile.am
+++ b/src/gallium/targets/libgl-xlib/Makefile.am
@@ -75,7 +75,7 @@ lib@GL_LIB@_la_LIBADD = \
$(GL_LIB_DEPS) \
$(CLOCK_LIB)
-if HAVE_MESA_LLVM
+if HAVE_GALLIUM_LLVM
lib@GL_LIB@_la_LIBADD += $(top_builddir)/src/gallium/drivers/llvmpipe/libllvmpipe.la $(LLVM_LIBS)
AM_CPPFLAGS += -DGALLIUM_LLVMPIPE
lib@GL_LIB@_la_LDFLAGS += $(LLVM_LDFLAGS)