summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/libgl-xlib/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-05 15:19:30 -0700
committerAndreas Boll <[email protected]>2013-01-10 22:01:10 +0100
commit0470fb4efe1b642788fc3b72016364c1f7a8deb4 (patch)
tree3a01eaa3b52dfb6d037b2e11bff93c7b1c8c32c9 /src/gallium/targets/libgl-xlib/Makefile.am
parentc14c801a03c4f470db777ac90a2c687087126a8a (diff)
targets/libgl-xlib: Convert to automake
v2: Andreas Boll <[email protected]> - Provide compatibility with scripts for the old Mesa build system
Diffstat (limited to 'src/gallium/targets/libgl-xlib/Makefile.am')
-rw-r--r--src/gallium/targets/libgl-xlib/Makefile.am70
1 files changed, 70 insertions, 0 deletions
diff --git a/src/gallium/targets/libgl-xlib/Makefile.am b/src/gallium/targets/libgl-xlib/Makefile.am
new file mode 100644
index 00000000000..2b697fc35d1
--- /dev/null
+++ b/src/gallium/targets/libgl-xlib/Makefile.am
@@ -0,0 +1,70 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+GL_MAJOR = 1
+GL_MINOR = 5
+GL_TINY = $(MESA_MAJOR)$(MESA_MINOR)0$(MESA_TINY)
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/src/mesa \
+ -I$(top_srcdir)/src/mesa/main \
+ -I$(top_srcdir)/src/gallium/include \
+ -I$(top_srcdir)/src/gallium/drivers \
+ -I$(top_srcdir)/src/gallium/state_trackers/glx/xlib \
+ -I$(top_srcdir)/src/gallium/auxiliary \
+ -DGALLIUM_SOFTPIPE \
+ -DGALLIUM_RBUG \
+ -DGALLIUM_TRACE \
+ -DGALLIUM_GALAHAD
+AM_CFLAGS = $(X11_CFLAGS)
+
+lib_LTLIBRARIES = libGL.la
+
+libGL_la_SOURCES = xlib.c
+libGL_la_LDFLAGS = -version-number $(GL_MAJOR):$(GL_MINOR):$(GL_TINY) -no-undefined
+
+libGL_la_LIBADD = \
+ $(top_builddir)/src/gallium/state_trackers/glx/libxlib.la \
+ $(top_builddir)/src/gallium/winsys/sw/xlib/libws_xlib.la \
+ $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
+ $(top_builddir)/src/gallium/drivers/rbug/librbug.la \
+ $(top_builddir)/src/gallium/drivers/galahad/libgalahad.la \
+ $(top_builddir)/src/mapi/glapi/libglapi.la \
+ $(top_builddir)/src/mesa/libmesagallium.la \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ -lpthread
+
+if HAVE_MESA_LLVM
+libGL_la_LIBADD += $(top_builddir)/src/gallium/drivers/llvmpipe/libllvmpipe.la $(LLVM_LIBS)
+AM_CPPFLAGS += -DGALLIUM_LLVMPIPE
+libGL_la_LDFLAGS += $(LLVM_LDFLAGS)
+else
+libGL_la_LIBADD += $(top_builddir)/src/gallium/drivers/softpipe/libsoftpipe.la
+endif
+
+# Provide compatibility with scripts for the old Mesa build system for
+# a while by putting a link to the driver into /lib of the build tree.
+all-local: libGL.la
+ $(MKDIR_P) $(top_builddir)/$(LIB_DIR)/gallium
+ ln -f .libs/libGL.so* $(top_builddir)/$(LIB_DIR)/gallium/