summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/gbm/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-13 10:10:14 -0700
committerAndreas Boll <[email protected]>2013-01-10 22:01:30 +0100
commit53c62d3fb0ee9aacc7a4aa08b4c42a3fb2127b2f (patch)
treebbcfb3cfc9b9cde855340df5b5d1ccd9d6ad77c5 /src/gallium/targets/gbm/Makefile.am
parentcdee0e808415214c27101103291a2be81eb02ad1 (diff)
targets/gbm: Convert to automake
Diffstat (limited to 'src/gallium/targets/gbm/Makefile.am')
-rw-r--r--src/gallium/targets/gbm/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/src/gallium/targets/gbm/Makefile.am b/src/gallium/targets/gbm/Makefile.am
new file mode 100644
index 00000000000..be2dd92e3f6
--- /dev/null
+++ b/src/gallium/targets/gbm/Makefile.am
@@ -0,0 +1,66 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+include $(top_srcdir)/src/gallium/Automake.inc
+
+gbmdir = $(libdir)/gbm
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/gallium/state_trackers/gbm \
+ -I$(top_srcdir)/src/gbm/main \
+ -I$(top_srcdir)/src/gallium/winsys \
+ $(GALLIUM_PIPE_LOADER_DEFINES) \
+ -DPIPE_SEARCH_DIR=\"$(gbmdir)\"
+
+AM_CFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(LIBUDEV_CFLAGS) \
+ $(LIBDRM_CFLAGS)
+
+gbm_LTLIBRARIES = gbm_gallium_drm.la
+
+gbm_gallium_drm_la_SOURCES = gbm.c
+
+gbm_gallium_drm_la_LIBADD = \
+ $(GALLIUM_PIPE_LOADER_LIBS) \
+ $(top_builddir)/src/gallium/state_trackers/gbm/libgbm.la \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(LIBUDEV_LIBS) \
+ $(LIBDRM_LIBS) \
+ -lm
+
+gbm_gallium_drm_la_LDFLAGS = -no-undefined -avoid-version -module
+
+# FIXME: this shouldn't be needed
+if HAVE_MESA_LLVM
+gbm_gallium_drm_la_LINK = $(CXXLINK) $(gbm_gallium_drm_la_LDFLAGS)
+# Mention a dummy pure C++ file to trigger generation of the $(LINK) variable
+nodist_EXTRA_gbm_gallium_drm_la_SOURCES = dummy-cpp.cpp
+
+gbm_gallium_drm_la_LIBADD += $(LLVM_LIBS)
+gbm_gallium_drm_la_LDFLAGS += $(LLVM_LDFLAGS)
+else
+gbm_gallium_drm_la_LINK = $(CXXLINK) $(gbm_gallium_drm_la_LDFLAGS)
+# Mention a dummy pure C file to trigger generation of the $(LINK) variable
+nodist_EXTRA_gbm_gallium_drm_la_SOURCES = dummy-c.c
+endif