summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/egl-static/SConscript
diff options
context:
space:
mode:
authorJose Fonseca <[email protected]>2015-03-03 16:01:22 +0000
committerJose Fonseca <[email protected]>2015-03-04 11:01:42 +0000
commit5564c361b5cc1f5ec4be3622d7f9be601e3c268a (patch)
treeedd2e212e86ad94257f5b4bf80659e4affee82a0 /src/gallium/targets/egl-static/SConscript
parent17b2825d760fb6a7b643e5f9c067d249a582cfdb (diff)
st/egl: Remove.
Largely superseeded by src/egl, and WGL/GLX_EXT_create_context_es_profile extensions. Note this will break Android.mk with gallium drivers -- somebody familiar with that build infrastructure will need to update it to use gallium drivers through egl_dri2. v2: Remove the _EGL_BUILT_IN_DRIVER_GALLIUM define from src/egl/main/Android.mk; and update the src/egl/main/Sconscript to create a SharedLibrary, add versioning, create symlink - copy the bits from egl-static, per Emil Velikov. Reviewed-by: Emil Velikov <[email protected]> v3: Disallow undefined symbols in libEGL.so. Update release notes
Diffstat (limited to 'src/gallium/targets/egl-static/SConscript')
-rw-r--r--src/gallium/targets/egl-static/SConscript114
1 files changed, 0 insertions, 114 deletions
diff --git a/src/gallium/targets/egl-static/SConscript b/src/gallium/targets/egl-static/SConscript
deleted file mode 100644
index e423d5d2b72..00000000000
--- a/src/gallium/targets/egl-static/SConscript
+++ /dev/null
@@ -1,114 +0,0 @@
-#######################################################################
-# SConscript for egl-static target
-
-Import('*')
-
-env = env.Clone()
-
-env.Append(CPPPATH = [
- '#/include',
- '#/src/loader',
- '#/src/egl/main',
- '#/src/gallium/auxiliary',
- '#/src/gallium/drivers',
- '#/src/gallium/include',
- '#/src/gallium/winsys',
- '#/src/gallium/state_trackers/egl',
- '#/src/gallium/state_trackers/vega',
- '#/src/mesa',
-])
-
-env.Append(CPPDEFINES = [
- 'GALLIUM_SOFTPIPE',
- 'GALLIUM_RBUG',
- 'GALLIUM_TRACE',
- 'GALLIUM_GALAHAD',
- '_EGL_MAIN=_eglBuiltInDriverGALLIUM',
-])
-
-env.Prepend(LIBS = [
- softpipe,
- rbug,
- trace,
- galahad,
- libloader,
- mesautil,
- gallium,
- egl,
- st_egl,
-])
-
-if env['llvm']:
- env.Append(CPPDEFINES = ['GALLIUM_LLVMPIPE'])
- env.Prepend(LIBS = [llvmpipe])
-
-sources = [
- 'egl.c',
- 'egl_pipe.c',
- 'egl_st.c',
-]
-
-if env['platform'] == 'windows':
- sources.append('#src/egl/main/egl.def')
-
- env.Append(LIBS = [
- 'gdi32',
- 'user32',
- 'kernel32',
- 'ws2_32',
- ])
-
- env.Prepend(LIBS = [
- ws_gdi,
- ])
-
-# OpenGL ES and OpenGL
-if env['gles']:
- env.Append(CPPDEFINES = [
- 'FEATURE_GL=1',
- 'FEATURE_ES1=1',
- 'FEATURE_ES2=1'
- ])
- env.Prepend(LIBPATH = [shared_glapi.dir])
- # manually add LIBPREFIX on windows
- glapi_name = 'glapi' if env['platform'] != 'windows' else 'libglapi'
- env.Prepend(LIBS = [glapi_name, glsl, mesa])
-
-# OpenVG
-if True:
- env.Append(CPPDEFINES = ['FEATURE_VG=1'])
- env.Prepend(LIBPATH = [openvg.dir])
- # manually add LIBPREFIX on windows
- openvg_name = 'OpenVG' if env['platform'] != 'windows' else 'libOpenVG'
- env.Prepend(LIBS = [openvg_name, st_vega])
-
-if env['HAVE_X11']:
- env.Prepend(LIBS = [
- ws_xlib,
- ])
- env.PkgUseModules('X11')
-
-# pipe drivers
-if env['HAVE_DRM']:
- env.PkgUseModules('DRM')
-
- env.Append(CPPDEFINES = ['GALLIUM_VMWGFX'])
- env.Prepend(LIBS = [
- svgadrm,
- svga,
- ])
-
-# libEGL.dll
-env['LIBPREFIX'] = 'lib'
-env['SHLIBPREFIX'] = 'lib'
-
-egl_gallium = env.SharedLibrary(
- target ='EGL',
- source = sources,
-)
-
-env.Depends(egl_gallium, [openvg])
-
-egl_gallium = env.InstallSharedLibrary(egl_gallium, version=(1, 4, 0))
-
-env.Alias('egl-gallium', egl_gallium)