summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-10 14:56:39 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commit6a9ad20b7c989d0a35f738d33c34bb2ee7c82695 (patch)
tree9e31601de5074db4c4b09e381055b4d64cc4ccb5 /src/gallium/targets/dri/meson.build
parentde24d61765011ed4bfc169b8ad8cf67e86b1f3bd (diff)
meson: build llvmpipe
Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/gallium/targets/dri/meson.build')
-rw-r--r--src/gallium/targets/dri/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/gallium/targets/dri/meson.build b/src/gallium/targets/dri/meson.build
index 2601f151f0e..2dc0de6a4d0 100644
--- a/src/gallium/targets/dri/meson.build
+++ b/src/gallium/targets/dri/meson.build
@@ -71,6 +71,10 @@ if with_gallium_softpipe
if with_gallium_drisw_kms
gallium_dri_drivers += 'kms_swrast_dri.so'
endif
+ if with_llvm
+ gallium_dri_c_args += '-DGALLIUM_LLVMPIPE'
+ gallium_dri_link_with += libllvmpipe
+ endif
endif
libgallium_dri = shared_library(