aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2018-10-23 12:33:09 -0700
committerEric Anholt <[email protected]>2019-01-28 09:35:45 -0800
commited65aeec7810a7d98a19461ba933bd77268cb0f6 (patch)
treef4d28071e942e011002ec831eb9b4acd80268ebd /src/gallium/targets/dri/meson.build
parentafeef3cacf35376a0c31f0871b57628cafd90ccb (diff)
pl111: Rename the pl111 driver to "kmsro".
The vc4 driver can do prime sharing to many different KMS-only devices, such as the various tinydrm drivers for SPI-attached displays. Rename the driver away from "pl111" to represent what it will actually support: various sorts of KMS displays with the renderonly layer used to attach a GPU. Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Christian Gmeiner <[email protected]> Acked-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/targets/dri/meson.build')
-rw-r--r--src/gallium/targets/dri/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gallium/targets/dri/meson.build b/src/gallium/targets/dri/meson.build
index 51940a2f350..c1cb616b4da 100644
--- a/src/gallium/targets/dri/meson.build
+++ b/src/gallium/targets/dri/meson.build
@@ -56,13 +56,13 @@ libgallium_dri = shared_library(
dependencies : [
dep_selinux, dep_expat, dep_libdrm, dep_llvm, dep_thread,
driver_swrast, driver_r300, driver_r600, driver_radeonsi, driver_nouveau,
- driver_pl111, driver_v3d, driver_vc4, driver_freedreno, driver_etnaviv,
+ driver_kmsro, driver_v3d, driver_vc4, driver_freedreno, driver_etnaviv,
driver_imx, driver_tegra, driver_i915, driver_svga, driver_virgl,
driver_swr,
],
)
-foreach d : [[with_gallium_pl111, 'pl111_dri.so'],
+foreach d : [[with_gallium_kmsro, 'pl111_dri.so'],
[with_gallium_radeonsi, 'radeonsi_dri.so'],
[with_gallium_nouveau, 'nouveau_dri.so'],
[with_gallium_freedreno, ['msm_dri.so', 'kgsl_dri.so']],