summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/Makefile.am
diff options
context:
space:
mode:
authorRoland Scheidegger <[email protected]>2018-02-07 23:47:39 +0100
committerRoland Scheidegger <[email protected]>2018-02-07 23:47:39 +0100
commit09f49b9e50ee86e24c7e975f08535aa7237852a1 (patch)
treeb5b76d69f1110eccdd3f7d3d0aa78c3e8ec6e264 /src/gallium/targets/dri/Makefile.am
parent6f82b8d8d0a986aac28e7bec47fc313fb950475c (diff)
Revert "gallium: build ddebug, noop, rbug, trace as part of auxiliary"
This reverts commit 6f82b8d8d0a986aac28e7bec47fc313fb950475c. This broke scons build, and reportedly clover with autotools/meson too.
Diffstat (limited to 'src/gallium/targets/dri/Makefile.am')
-rw-r--r--src/gallium/targets/dri/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/gallium/targets/dri/Makefile.am b/src/gallium/targets/dri/Makefile.am
index 99688285184..1d05d91a610 100644
--- a/src/gallium/targets/dri/Makefile.am
+++ b/src/gallium/targets/dri/Makefile.am
@@ -9,7 +9,11 @@ AM_CFLAGS = \
$(GALLIUM_TARGET_CFLAGS)
AM_CPPFLAGS = \
- $(DEFINES)
+ $(DEFINES) \
+ -DGALLIUM_DDEBUG \
+ -DGALLIUM_NOOP \
+ -DGALLIUM_RBUG \
+ -DGALLIUM_TRACE
dridir = $(DRI_DRIVER_INSTALL_DIR)
dri_LTLIBRARIES = gallium_dri.la
@@ -43,6 +47,10 @@ gallium_dri_la_LIBADD = \
$(top_builddir)/src/gallium/state_trackers/dri/libdri.la \
$(top_builddir)/src/gallium/auxiliary/libgalliumvl.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(top_builddir)/src/gallium/drivers/ddebug/libddebug.la \
+ $(top_builddir)/src/gallium/drivers/noop/libnoop.la \
+ $(top_builddir)/src/gallium/drivers/rbug/librbug.la \
+ $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
$(top_builddir)/src/mapi/shared-glapi/libglapi.la \
$(SELINUX_LIBS) \
$(EXPAT_LIBS) \