summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-16 13:31:10 +0100
committerEmil Velikov <[email protected]>2014-07-02 10:52:53 +0100
commit100e654b2577ec69100f5d1695f4401d74109cf0 (patch)
treee1a2ddf84a7c61aa8aa1a5efc0f79ec23c08e5fd /src/gallium/targets/dri/Makefile.am
parent0a4be815f458ea7a55b7f880b3108dba4de62281 (diff)
targets/dri-ilo: Convert to static/shared pipe-driver
Cc: Chia-I Wu <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Tested-by: Rob Clark <[email protected]> Tested-by: Thomas Helland <thomashelland90 at gmail.com> Acked-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/targets/dri/Makefile.am')
-rw-r--r--src/gallium/targets/dri/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/gallium/targets/dri/Makefile.am b/src/gallium/targets/dri/Makefile.am
index 1a520a21dd1..613b798c393 100644
--- a/src/gallium/targets/dri/Makefile.am
+++ b/src/gallium/targets/dri/Makefile.am
@@ -59,6 +59,15 @@ STATIC_TARGET_LIB_DEPS += \
$(INTEL_LIBS)
endif
+if HAVE_GALLIUM_ILO
+MEGADRIVERS += ilo
+STATIC_TARGET_CPPFLAGS += -DGALLIUM_ILO
+STATIC_TARGET_LIB_DEPS += \
+ $(top_builddir)/src/gallium/winsys/intel/drm/libintelwinsys.la \
+ $(top_builddir)/src/gallium/drivers/ilo/libilo.la \
+ $(INTEL_LIBS)
+endif
+
if HAVE_GALLIUM_NOUVEAU
MEGADRIVERS += nouveau
STATIC_TARGET_CPPFLAGS += -DGALLIUM_NOUVEAU