summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-21 12:45:54 +0100
committerEmil Velikov <[email protected]>2014-07-02 10:52:53 +0100
commit0a4be815f458ea7a55b7f880b3108dba4de62281 (patch)
tree476631734ba38b6cb38546c5f5d842696f55e80c /src/gallium/targets/dri/Makefile.am
parent231063b03234e078c63da10c65f070799f945156 (diff)
targets/dri-i915: Convert to static/shared pipe-drivers
v2: - Drop inclusion of the winsys wrapper and softpipe/llvmpipe. - Remove old Makefile.am, target.c. - Correctly append i915 to the megadrivers list. Cc: Stephane Marchesin <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Tested-by: Rob Clark <[email protected]> Tested-by: Thomas Helland <thomashelland90 at gmail.com> Acked-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/targets/dri/Makefile.am')
-rw-r--r--src/gallium/targets/dri/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/gallium/targets/dri/Makefile.am b/src/gallium/targets/dri/Makefile.am
index e4d9a7e9794..1a520a21dd1 100644
--- a/src/gallium/targets/dri/Makefile.am
+++ b/src/gallium/targets/dri/Makefile.am
@@ -50,6 +50,15 @@ STATIC_TARGET_CPPFLAGS =
STATIC_TARGET_LIB_DEPS = \
$(top_builddir)/src/loader/libloader.la
+if HAVE_GALLIUM_I915
+MEGADRIVERS += i915
+STATIC_TARGET_CPPFLAGS += -DGALLIUM_I915
+STATIC_TARGET_LIB_DEPS += \
+ $(top_builddir)/src/gallium/winsys/i915/drm/libi915drm.la \
+ $(top_builddir)/src/gallium/drivers/i915/libi915.la \
+ $(INTEL_LIBS)
+endif
+
if HAVE_GALLIUM_NOUVEAU
MEGADRIVERS += nouveau
STATIC_TARGET_CPPFLAGS += -DGALLIUM_NOUVEAU