summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/Makefile.am
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2018-04-07 14:01:12 -0400
committerMarek Olšák <[email protected]>2018-04-13 14:08:14 -0400
commit6ff0c6f4ebcb87ea6c6fe5a4ba90b548f666067d (patch)
tree30926986da28bb0b67b857d8f2cf7eeaa77f8773 /src/gallium/targets/dri/Makefile.am
parent918b798668c5465d85ca542423e4cf525dc79b31 (diff)
gallium: move ddebug, noop, rbug, trace to auxiliary to improve build times
which also simplifies the build scripts.
Diffstat (limited to 'src/gallium/targets/dri/Makefile.am')
-rw-r--r--src/gallium/targets/dri/Makefile.am10
1 files changed, 1 insertions, 9 deletions
diff --git a/src/gallium/targets/dri/Makefile.am b/src/gallium/targets/dri/Makefile.am
index c6a4c215905..a0778b64e58 100644
--- a/src/gallium/targets/dri/Makefile.am
+++ b/src/gallium/targets/dri/Makefile.am
@@ -9,11 +9,7 @@ AM_CFLAGS = \
$(GALLIUM_TARGET_CFLAGS)
AM_CPPFLAGS = \
- $(DEFINES) \
- -DGALLIUM_DDEBUG \
- -DGALLIUM_NOOP \
- -DGALLIUM_RBUG \
- -DGALLIUM_TRACE
+ $(DEFINES)
dridir = $(DRI_DRIVER_INSTALL_DIR)
dri_LTLIBRARIES = gallium_dri.la
@@ -47,10 +43,6 @@ gallium_dri_la_LIBADD = \
$(top_builddir)/src/gallium/state_trackers/dri/libdri.la \
$(top_builddir)/src/gallium/auxiliary/libgalliumvl.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
- $(top_builddir)/src/gallium/drivers/ddebug/libddebug.la \
- $(top_builddir)/src/gallium/drivers/noop/libnoop.la \
- $(top_builddir)/src/gallium/drivers/rbug/librbug.la \
- $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
$(top_builddir)/src/mapi/shared-glapi/libglapi.la \
$(LIBDRM_LIBS) \
$(SELINUX_LIBS) \