aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri-ilo/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-16 13:31:10 +0100
committerEmil Velikov <[email protected]>2014-07-02 10:52:53 +0100
commit100e654b2577ec69100f5d1695f4401d74109cf0 (patch)
treee1a2ddf84a7c61aa8aa1a5efc0f79ec23c08e5fd /src/gallium/targets/dri-ilo/Makefile.am
parent0a4be815f458ea7a55b7f880b3108dba4de62281 (diff)
targets/dri-ilo: Convert to static/shared pipe-driver
Cc: Chia-I Wu <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Tested-by: Rob Clark <[email protected]> Tested-by: Thomas Helland <thomashelland90 at gmail.com> Acked-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/targets/dri-ilo/Makefile.am')
-rw-r--r--src/gallium/targets/dri-ilo/Makefile.am52
1 files changed, 0 insertions, 52 deletions
diff --git a/src/gallium/targets/dri-ilo/Makefile.am b/src/gallium/targets/dri-ilo/Makefile.am
deleted file mode 100644
index 41eab06bcdb..00000000000
--- a/src/gallium/targets/dri-ilo/Makefile.am
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright © 2012 Intel Corporation
-# Copyright © 2013 LunarG, Inc.
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice (including the next
-# paragraph) shall be included in all copies or substantial portions of the
-# Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
-# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
-# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-# DEALINGS IN THE SOFTWARE.
-
-include $(top_srcdir)/src/gallium/Automake.inc
-
-AM_CFLAGS = \
- $(GALLIUM_DRI_CFLAGS)
-AM_CPPFLAGS = \
- -DGALLIUM_RBUG \
- -DGALLIUM_TRACE \
- -DGALLIUM_GALAHAD
-
-dridir = $(DRI_DRIVER_INSTALL_DIR)
-dri_LTLIBRARIES = ilo_dri.la
-
-nodist_EXTRA_ilo_dri_la_SOURCES = dummy.cpp
-ilo_dri_la_SOURCES = target.c
-
-ilo_dri_la_LDFLAGS = $(GALLIUM_DRI_LINKER_FLAGS)
-
-ilo_dri_la_LIBADD = \
- $(top_builddir)/src/mesa/drivers/dri/common/libdricommon.la \
- $(top_builddir)/src/gallium/state_trackers/dri/drm/libdridrm.la \
- $(top_builddir)/src/gallium/winsys/intel/drm/libintelwinsys.la \
- $(top_builddir)/src/gallium/drivers/galahad/libgalahad.la \
- $(top_builddir)/src/gallium/drivers/trace/libtrace.la \
- $(top_builddir)/src/gallium/drivers/rbug/librbug.la \
- $(top_builddir)/src/gallium/drivers/ilo/libilo.la \
- $(GALLIUM_DRI_LIB_DEPS) \
- $(INTEL_LIBS)
-
-include $(top_srcdir)/install-gallium-links.mk