summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-12 16:33:58 +0100
committerEmil Velikov <[email protected]>2014-06-26 14:05:13 +0100
commitb1f4a9681fba954bb7f3e8c4877e7ad62703cb0b (patch)
tree953464f4e01136cea912a52be997da5579873be4 /src/gallium/targets/Makefile.am
parentc35cf3400f57c5ed60df4c4a801a71fe897edfb8 (diff)
targets/omx-nouveau: convert to static/shared pipe-drivers
Similar to the vdpau/xvmc targets, we're going to convert the multiple target libraries into a single one. The library can be built with the relevant pipe-drivers statically linked in, or loaded as shared modules. Currently we default to static. Note: Make sure to rebuild the .omxregister file, by executing $ omxregister-bellagio If you have more than one omx library (libomx-radeonsi, libomx-r600), make sure to temporary move the unused one. By the end of the series there will be only one library that will be used for all hardware - r600, radeonsi and nouveau. Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/targets/Makefile.am')
-rw-r--r--src/gallium/targets/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/gallium/targets/Makefile.am b/src/gallium/targets/Makefile.am
index e96224eaf35..1af0c446eff 100644
--- a/src/gallium/targets/Makefile.am
+++ b/src/gallium/targets/Makefile.am
@@ -26,6 +26,10 @@ if HAVE_X11_DRIVER
SUBDIRS += libgl-xlib
endif
+if HAVE_ST_OMX
+SUBDIRS += omx
+endif
+
if HAVE_GALLIUM_OSMESA
SUBDIRS += osmesa
endif
@@ -104,10 +108,6 @@ if HAVE_GALLIUM_NOUVEAU
if HAVE_DRI2
SUBDIRS += dri-nouveau
endif
-
-if HAVE_ST_OMX
-SUBDIRS += omx-nouveau
-endif
endif
if HAVE_GALLIUM_SOFTPIPE