summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-12 15:54:15 +0100
committerEmil Velikov <[email protected]>2014-06-22 23:06:04 +0100
commitdc01ca44a796ab7cc5452913c495ba90ebb648b8 (patch)
treeb6d840952ff80ce302e5f5ac9f070a9e38617498 /src/gallium/targets/Makefile.am
parent291d70210dd249c663f8c3b92ac9cf47335630bd (diff)
targets/xvmc-nouveau: convert to static/shared pipe-drivers
Similar to vdpau targets, we're going to convert the individual target libraries into a single one. The library can be built with the relevant pipe-drivers statically linked in, or loaded as shared modules. Currently we default to static. Cc: Ilia Mirkin <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Tested-by: Thomas Helland <thomashelland90 at gmail.com>
Diffstat (limited to 'src/gallium/targets/Makefile.am')
-rw-r--r--src/gallium/targets/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/gallium/targets/Makefile.am b/src/gallium/targets/Makefile.am
index c31a22e7cd2..0fbf0d7a34f 100644
--- a/src/gallium/targets/Makefile.am
+++ b/src/gallium/targets/Makefile.am
@@ -42,6 +42,10 @@ if HAVE_ST_XA
SUBDIRS += xa
endif
+if HAVE_ST_XVMC
+SUBDIRS += xvmc
+endif
+
if HAVE_CLOVER
SUBDIRS += opencl
endif
@@ -105,10 +109,6 @@ if HAVE_DRI2
SUBDIRS += dri-nouveau
endif
-if HAVE_ST_XVMC
-SUBDIRS += xvmc-nouveau
-endif
-
if HAVE_ST_OMX
SUBDIRS += omx-nouveau
endif