summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-12 16:38:54 +0100
committerEmil Velikov <[email protected]>2014-06-26 14:05:13 +0100
commitd23497c256539d4a49120cfeeb043c9f2ef8e09b (patch)
treee466e616d3b0b42ed47fd59f810324d24d102083 /src/gallium/targets/Makefile.am
parentb1f4a9681fba954bb7f3e8c4877e7ad62703cb0b (diff)
targets/r600/omx: convert to static/shared pipe-drivers
The r600 counterpart of previous commit - now the libomx-r600 is built into the libomx-mesa library. Providing a single library per API. v2: Include the radeon winsys only when there is a user for it. v3: Correcly include the winsys. Now with extra brown bag :\ Note: Make sure to rebuild the .omxregister file, by executing $ omxregister-bellagio If you have more than one omx library (libomx-radeonsi, libomx-r600), make sure to temporary move the unused one. By the end of the series there will be only one library that will be used for all hardware - r600, radeonsi and nouveau. Cc: Leo Liu <[email protected]> Cc: Christian König <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Christian König <[email protected]>
Diffstat (limited to 'src/gallium/targets/Makefile.am')
-rw-r--r--src/gallium/targets/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/gallium/targets/Makefile.am b/src/gallium/targets/Makefile.am
index 1af0c446eff..9612eb2b2ad 100644
--- a/src/gallium/targets/Makefile.am
+++ b/src/gallium/targets/Makefile.am
@@ -88,10 +88,6 @@ if HAVE_GALLIUM_R600
if HAVE_DRI2
SUBDIRS += r600/dri
endif
-
-if HAVE_ST_OMX
-SUBDIRS += r600/omx
-endif
endif
if HAVE_GALLIUM_RADEONSI