summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/Makefile.am
diff options
context:
space:
mode:
authorRob Clark <[email protected]>2014-02-10 10:43:11 -0500
committerRob Clark <[email protected]>2014-02-16 08:36:19 -0500
commit42158926c6d7d3ddbe61b9a04d60544ff1b50a96 (patch)
tree13a31743d343a5f31684bbf836d1e4b088e2fe25 /src/gallium/targets/Makefile.am
parenta122c75599cf196b7997fbc5ec2854ebd65af408 (diff)
st/xa: use pipe-loader to get screen
This lets multiple gallium drivers use XA. Signed-off-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/gallium/targets/Makefile.am')
-rw-r--r--src/gallium/targets/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/gallium/targets/Makefile.am b/src/gallium/targets/Makefile.am
index a3369140844..871b31d9512 100644
--- a/src/gallium/targets/Makefile.am
+++ b/src/gallium/targets/Makefile.am
@@ -34,6 +34,10 @@ if HAVE_GALLIUM_GBM
SUBDIRS += gbm
endif
+if HAVE_ST_XA
+SUBDIRS += xa
+endif
+
if HAVE_CLOVER
SUBDIRS += opencl
endif
@@ -42,10 +46,6 @@ if HAVE_GALLIUM_SVGA
if HAVE_DRI
SUBDIRS += dri-vmwgfx
endif
-
-if HAVE_ST_XA
-SUBDIRS += xa-vmwgfx
-endif
endif
if HAVE_GALLIUM_FREEDRENO