aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-16 14:23:50 +0100
committerEmil Velikov <[email protected]>2014-07-02 10:52:53 +0100
commit6eabddd531918b922619cb16f1250b211d5c193a (patch)
tree4cbc70b0ea712f2e23e073f8f55e2ed94538bae8 /src/gallium/targets/Makefile.am
parent9a7fd2954fa24a6d899c1fa5e7be55723d6892b8 (diff)
targets/dri-nouveau: Convert to static/shared pipe-drivers
Similiar to other targets, we'd like to convert all the separate targets into a single one, thus we'll minimize the duplication and overall size of mesa. The conversion per API basis, with the drivers available either statically or shared. Currently the former is the default. v2: Correctly append the version script to the linker flags. Signed-off-by: Emil Velikov <[email protected]> Tested-by: Rob Clark <[email protected]> Tested-by: Thomas Helland <thomashelland90 at gmail.com> Acked-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/targets/Makefile.am')
-rw-r--r--src/gallium/targets/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/gallium/targets/Makefile.am b/src/gallium/targets/Makefile.am
index d86cd33af94..1a44c56ccfe 100644
--- a/src/gallium/targets/Makefile.am
+++ b/src/gallium/targets/Makefile.am
@@ -22,6 +22,10 @@
SUBDIRS =
+if HAVE_DRI2
+SUBDIRS += dri
+endif
+
if HAVE_X11_DRIVER
SUBDIRS += libgl-xlib
endif
@@ -96,12 +100,6 @@ SUBDIRS += radeonsi/dri
endif
endif
-if HAVE_GALLIUM_NOUVEAU
-if HAVE_DRI2
-SUBDIRS += dri-nouveau
-endif
-endif
-
if HAVE_GALLIUM_SOFTPIPE
if HAVE_DRISW
SUBDIRS += dri-swrast