summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/va/Makefile.am
diff options
context:
space:
mode:
authorChristian König <[email protected]>2014-07-02 16:35:28 -0400
committerLeo Liu <[email protected]>2014-10-01 13:21:36 -0400
commit3867933ecbc34ed1f68d735282580ca1e4eedea1 (patch)
tree369b448f538296e2fa3193af921b0666ae75912d /src/gallium/state_trackers/va/Makefile.am
parent0eb8f8998114855d8d200a70c357d482e8f444fc (diff)
st/va: skeleton VAAPI state tracker
This patch adds a skeleton VA-API state tracker, which is filled with live in the subsequent patches. v2: fixes in configure.ac and va state_tracker Makefile.am v3: do not link against libva. detect libva version, and correctly set driver entrypoint name. rebase(cleanup) targets/va/Makefile.am v4: cleanup va version auto detection add back targets/va/va.sym Signed-off-by: Christian König <[email protected]> Signed-off-by: Leo Liu <[email protected]> Reviewed-by: Alex Deucher <[email protected]>
Diffstat (limited to 'src/gallium/state_trackers/va/Makefile.am')
-rw-r--r--src/gallium/state_trackers/va/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/gallium/state_trackers/va/Makefile.am b/src/gallium/state_trackers/va/Makefile.am
new file mode 100644
index 00000000000..ec64c3f4611
--- /dev/null
+++ b/src/gallium/state_trackers/va/Makefile.am
@@ -0,0 +1,37 @@
+# Copyright 2014 Advanced Micro Devices, Inc.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(VISIBILITY_CFLAGS) \
+ $(VA_CFLAGS) \
+ -DVA_DRIVER_INIT_FUNC="__vaDriverInit_$(VA_MAJOR)_$(VA_MINOR)"
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include
+
+noinst_LTLIBRARIES = libvatracker.la
+
+libvatracker_la_SOURCES = $(C_SOURCES)