summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/omx/Makefile.am
diff options
context:
space:
mode:
authorChristian König <[email protected]>2013-08-05 11:41:27 -0600
committerChristian König <[email protected]>2014-02-13 11:11:24 +0100
commit0ef3ce415522c77f11477c340efeef7b61cb8cb3 (patch)
treeeded5723a185e5b682816b5bb32b0074a961c91c /src/gallium/state_trackers/omx/Makefile.am
parent9ff0cf903dc4ed806961d1e099d1308322092892 (diff)
st/omx: initial OpenMAX H264 encoder v7
v2 (chk): fix eos handling v3 (leo): implement scaling configuration support v4 (leo): fix bitrate bug v5 (chk): add workaround for bug in Bellagio v6 (chk): fix div by 0 if framerate isn't known, user separate pipe object for scale and transfer, always flush the transfer pipe before encoding v7 (chk): make suggested changes, cleanup a bit more, only advertise encoder on supported hardware Signed-off-by: Christian König <[email protected]> Signed-off-by: Leo Liu <[email protected]>
Diffstat (limited to 'src/gallium/state_trackers/omx/Makefile.am')
-rw-r--r--src/gallium/state_trackers/omx/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/gallium/state_trackers/omx/Makefile.am b/src/gallium/state_trackers/omx/Makefile.am
index 7972d798d6b..83b3f90ad3c 100644
--- a/src/gallium/state_trackers/omx/Makefile.am
+++ b/src/gallium/state_trackers/omx/Makefile.am
@@ -33,4 +33,5 @@ libomxtracker_la_SOURCES = \
entrypoint.c \
vid_dec.c \
vid_dec_mpeg12.c \
- vid_dec_h264.c
+ vid_dec_h264.c \
+ vid_enc.c