summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/egl/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2013-09-22 17:22:15 +0100
committerTom Stellard <[email protected]>2013-10-01 07:29:51 -0700
commit4e9028b63818e7075fd3dc304e8ae3e8107b155f (patch)
treeaaa044daaf29a5aecb1b4f95c94b3ab53e6bba4c /src/gallium/state_trackers/egl/Makefile.am
parentedd11ece383416bf9a1c6ced36214f7fd240a274 (diff)
st/egl: consolidate C sources lists into Makefile.sources
Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/state_trackers/egl/Makefile.am')
-rw-r--r--src/gallium/state_trackers/egl/Makefile.am31
1 files changed, 7 insertions, 24 deletions
diff --git a/src/gallium/state_trackers/egl/Makefile.am b/src/gallium/state_trackers/egl/Makefile.am
index 126fafc4508..1d84d6194fa 100644
--- a/src/gallium/state_trackers/egl/Makefile.am
+++ b/src/gallium/state_trackers/egl/Makefile.am
@@ -22,6 +22,7 @@
AUTOMAKE_OPTIONS = subdir-objects
+include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
AM_CFLAGS = $(GALLIUM_CFLAGS)
@@ -31,23 +32,10 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/include
noinst_LTLIBRARIES = libegl.la
-libegl_la_SOURCES = \
- common/egl_g3d_api.c \
- common/egl_g3d.c \
- common/egl_g3d_image.c \
- common/egl_g3d_st.c \
- common/egl_g3d_sync.c \
- common/native_helper.c \
- common/native_wayland_drm_bufmgr.c
+libegl_la_SOURCES = $(common_SOURCES)
if HAVE_EGL_PLATFORM_X11
-libegl_la_SOURCES += \
- x11/glxinit.c \
- x11/native_dri2.c \
- x11/native_x11.c \
- x11/native_ximage.c \
- x11/x11_screen.c \
- x11/dri2.c
+libegl_la_SOURCES += $(x11_SOURCES) $(x11_drm_SOURCES)
AM_CFLAGS += \
$(X11_CFLAGS) \
$(LIBDRM_CFLAGS) \
@@ -61,10 +49,7 @@ AM_CPPFLAGS += \
endif
if HAVE_EGL_PLATFORM_WAYLAND
-libegl_la_SOURCES += \
- wayland/native_drm.c \
- wayland/native_shm.c \
- wayland/native_wayland.c
+libegl_la_SOURCES += $(wayland_SOURCES)
AM_CFLAGS += \
$(LIBDRM_CFLAGS) \
$(WAYLAND_CFLAGS)
@@ -77,9 +62,7 @@ AM_CPPFLAGS += \
endif
if HAVE_EGL_PLATFORM_DRM
-libegl_la_SOURCES += \
- drm/modeset.c \
- drm/native_drm.c
+libegl_la_SOURCES += $(drm_SOURCES)
AM_CFLAGS += \
$(LIBDRM_CFLAGS)
AM_CPPFLAGS += \
@@ -90,14 +73,14 @@ AM_CPPFLAGS += \
endif
if HAVE_EGL_PLATFORM_FBDEV
-libegl_la_SOURCES += fbdev/native_fbdev.c
+libegl_la_SOURCES += $(fbdev_SOURCES)
AM_CPPFLAGS += \
-I$(top_srcdir)/src/gallium/winsys/sw \
-DHAVE_FBDEV_BACKEND
endif
if HAVE_EGL_PLATFORM_NULL
-libegl_la_SOURCES += null/native_null.c
+libegl_la_SOURCES += $(null_SOURCES)
AM_CPPFLAGS += \
-I$(top_srcdir)/src/gallium/winsys/sw \
-DHAVE_NULL_BACKEND