summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/egl/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-08-18 23:50:06 +0100
committerEmil Velikov <[email protected]>2014-08-28 21:24:37 +0100
commitafdc44deca806f9439d70e0b404045ff80f12adc (patch)
treef1f9fc7910c1b7314a084b2391152ee3a038a3f7 /src/gallium/state_trackers/egl/Makefile.am
parent30f3df4e538a668f53a31f0b376e06116b722a10 (diff)
st/egl: cleanup sw winsys header inclusions
- Drop duplicate include compiler directives. - Leave the sw/ prefix for all the software winsys headers. Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/state_trackers/egl/Makefile.am')
-rw-r--r--src/gallium/state_trackers/egl/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/src/gallium/state_trackers/egl/Makefile.am b/src/gallium/state_trackers/egl/Makefile.am
index 0ea218d37ce..3e917c1ac3c 100644
--- a/src/gallium/state_trackers/egl/Makefile.am
+++ b/src/gallium/state_trackers/egl/Makefile.am
@@ -31,7 +31,8 @@ AM_CFLAGS = \
AM_CPPFLAGS = \
-I$(top_srcdir)/src/egl/main \
- -I$(top_builddir)/src/egl/wayland/wayland-drm/
+ -I$(top_builddir)/src/egl/wayland/wayland-drm/ \
+ -I$(top_srcdir)/src/gallium/winsys
noinst_LTLIBRARIES = libegl.la
libegl_la_SOURCES = $(common_FILES)
@@ -43,8 +44,6 @@ AM_CFLAGS += \
$(LIBDRM_CFLAGS) \
$(DRI2PROTO_CFLAGS)
AM_CPPFLAGS += \
- -I$(top_srcdir)/src/gallium/winsys \
- -I$(top_srcdir)/src/gallium/drivers \
-I$(top_srcdir)/src/glx \
-I$(top_srcdir)/src/mapi \
-I$(top_srcdir)/src/mesa \
@@ -57,7 +56,6 @@ AM_CFLAGS += \
$(LIBDRM_CFLAGS) \
$(WAYLAND_CFLAGS)
AM_CPPFLAGS += \
- -I$(top_srcdir)/src/gallium/winsys \
-I$(top_srcdir)/src/egl/wayland/wayland-egl \
-I$(top_srcdir)/src/egl/wayland/wayland-drm \
-I$(top_builddir)/src/egl/wayland/wayland-drm \
@@ -70,7 +68,6 @@ AM_CFLAGS += \
$(LIBDRM_CFLAGS)
AM_CPPFLAGS += \
-I$(top_srcdir)/src/loader \
- -I$(top_srcdir)/src/gallium/winsys \
-I$(top_srcdir)/src/gbm/main \
-I$(top_srcdir)/src/gallium/state_trackers/gbm \
-DHAVE_DRM_BACKEND
@@ -79,14 +76,12 @@ endif
if HAVE_EGL_PLATFORM_FBDEV
libegl_la_SOURCES += $(fbdev_FILES)
AM_CPPFLAGS += \
- -I$(top_srcdir)/src/gallium/winsys/sw \
-DHAVE_FBDEV_BACKEND
endif
if HAVE_EGL_PLATFORM_NULL
libegl_la_SOURCES += $(null_FILES)
AM_CPPFLAGS += \
- -I$(top_srcdir)/src/gallium/winsys/sw \
-DHAVE_NULL_BACKEND
endif