summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/dri/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-08-12 23:18:23 +0100
committerEmil Velikov <[email protected]>2014-08-12 23:36:06 +0100
commit16873a6e62e2dc7de1f247e8cae1b40bd813a117 (patch)
tree1217bc441aa91928853f83fb445151857a2ed5c3 /src/gallium/state_trackers/dri/Makefile.am
parent2af28040d639dddbb7c258981a00eaf3dfcbcf03 (diff)
st/dri: define GALLIUM_SOFTPIPE when building kms_swrast
To avoid unresolved symbols in the DRI modules with earlier commit we wrapped the innards of dri_kms_init_screen() in a DRI_TARGET/GALLIUM_SOFTPIPE ifdef. At the same time we forgot to adds the defines to the st/dri build systems, breaking kms_swrast and gnome-continuous. Drop the DRI_TARGET define, we're already in st/DRI. Reported-by: Jasper St. Pierre <[email protected]> Reported-by: Vadim Rutkovsky <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/state_trackers/dri/Makefile.am')
-rw-r--r--src/gallium/state_trackers/dri/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/gallium/state_trackers/dri/Makefile.am b/src/gallium/state_trackers/dri/Makefile.am
index bda75c3f9b8..aa196ebbb11 100644
--- a/src/gallium/state_trackers/dri/Makefile.am
+++ b/src/gallium/state_trackers/dri/Makefile.am
@@ -40,6 +40,11 @@ AM_CPPFLAGS = \
if HAVE_GALLIUM_STATIC_TARGETS
AM_CPPFLAGS += \
-DGALLIUM_STATIC_TARGETS=1
+
+if HAVE_GALLIUM_SOFTPIPE
+AM_CPPFLAGS += \
+ -DGALLIUM_SOFTPIPE
+endif # HAVE_GALLIUM_SOFTPIPE
endif # HAVE_GALLIUM_STATIC_TARGETS
noinst_LTLIBRARIES = libdri.la