aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-13 17:58:51 -0800
committerDylan Baker <[email protected]>2017-12-04 14:36:58 -0800
commit6b4c7047d57178d3362a710ad503057c6a582ca3 (patch)
tree428d06c61e3044acaae3992f10fab034a47e298b /src/gallium/meson.build
parent0ba909f0f111824223bc38563d1a6bc73e69c2cc (diff)
meson: build gallium nine state_tracker
v2: - set d3d_drivers_path instead of dri_drivers_path - Fix nine guard to check for all relavent gallium drivers - Link with libswdri and libswkmsdri when necessary - Fix pkg-config generation - Add missing comma Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index e700d03da93..7e841633a9c 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -134,6 +134,9 @@ endif
if with_gallium_xa
subdir('state_trackers/xa')
endif
+if with_gallium_st_nine
+ subdir('state_trackers/nine')
+endif
# TODO: SWR
# TODO: clover
if with_dri
@@ -164,5 +167,7 @@ endif
if with_gallium_xa
subdir('targets/xa')
endif
-# TODO: nine
+if with_gallium_st_nine
+ subdir('targets/d3dadapter9')
+endif
# TODO: tests