summaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-14 17:04:27 -0800
committerDylan Baker <[email protected]>2017-11-20 14:28:31 -0800
commitc8417c8d25e57b00e7202908d93e56daf54513af (patch)
tree1e2b5874a8a6e89f5ee9d612e7b03d2b5e70cee8 /src/gallium/meson.build
parent689fb7471671991b3971eeb4f0fa8aa3721c4822 (diff)
meson: Guard the gallium dri componenet
Currently the target has a redundant guard, and the state tracker isn't properly guarded. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index 7ccf4819079..07a97f72490 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -73,7 +73,9 @@ endif
if with_glx == 'gallium-xlib'
subdir('winsys/sw/xlib')
endif
-subdir('state_trackers/dri')
+if with_dri
+ subdir('state_trackers/dri')
+endif
if with_osmesa == 'gallium'
subdir('state_trackers/osmesa')
endif
@@ -87,7 +89,7 @@ endif
# TODO: SWR
# TODO: virgl
# TODO: clover
-if with_dri and with_gallium
+if with_dri
subdir('targets/dri')
endif
if with_osmesa == 'gallium'