summaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-09-28 22:25:02 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commitb1b65397d0c4978e36a84c0a1c98a4bd6cb9588e (patch)
tree165535796a6ba46dcc4b64299ca8bd805838b827 /src/gallium/meson.build
parentaf9d276134d9af3b6145f10943eaf7bf1a6226b6 (diff)
meson: Build gallium auxiliary
v2: - guard gallivm files with "with_llvm" instead of "dep_llvm.found()" Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]> (v1)
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
new file mode 100644
index 00000000000..a9c36973ca1
--- /dev/null
+++ b/src/gallium/meson.build
@@ -0,0 +1,23 @@
+# Copyright © 2017 Dylan Baker
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+inc_gallium = include_directories('include')
+
+subdir('auxiliary')