summaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-03-06 11:32:23 -0800
committerDylan Baker <[email protected]>2018-03-07 13:30:53 -0800
commit2d3004ef1caafc44d0e7adeaf1fe2bf0dfa1eced (patch)
tree0b59a1f330a3c8c1a2e6ec3669e9adcc4a4309de /src/gallium/meson.build
parent55376cb31e2f495a4d872b4ffce2135c3365b873 (diff)
meson: combine state trackers and target if blocks
This is needed later since tizonia requires dri Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Jon Turney <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Tested-by: Julien Isorce <[email protected]> Tested-by: Karol Herbst <[email protected]>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build28
1 files changed, 7 insertions, 21 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index 7f49c285992..d3cbb76d94d 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -138,27 +138,6 @@ if with_gallium_virgl
else
driver_virgl = declare_dependency()
endif
-if with_gallium_vdpau
- subdir('state_trackers/vdpau')
-endif
-if with_gallium_xvmc
- subdir('state_trackers/xvmc')
-endif
-if with_gallium_omx
- subdir('state_trackers/omx')
-endif
-if with_gallium_va
- subdir('state_trackers/va')
-endif
-if with_gallium_xa
- subdir('state_trackers/xa')
-endif
-if with_gallium_st_nine
- subdir('state_trackers/nine')
-endif
-if with_platform_haiku
- subdir('state_trackers/hgl')
-endif
if with_gallium_opencl
# TODO: this isn't really clover specific, but ATM clover is the only
# consumer
@@ -184,24 +163,31 @@ if with_glx == 'gallium-xlib'
subdir('targets/libgl-xlib')
endif
if with_gallium_vdpau
+ subdir('state_trackers/vdpau')
subdir('targets/vdpau')
endif
if with_gallium_xvmc
+ subdir('state_trackers/xvmc')
subdir('targets/xvmc')
endif
if with_gallium_omx
+ subdir('state_trackers/omx')
subdir('targets/omx')
endif
if with_gallium_va
+ subdir('state_trackers/va')
subdir('targets/va')
endif
if with_gallium_xa
+ subdir('state_trackers/xa')
subdir('targets/xa')
endif
if with_platform_haiku
+ subdir('state_trackers/hgl')
subdir('targets/haiku-softpipe')
endif
if with_gallium_st_nine
+ subdir('state_trackers/nine')
subdir('targets/d3dadapter9')
endif
# TODO: tests