summaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-26 14:19:19 -0700
committerDylan Baker <[email protected]>2017-11-28 14:06:36 -0800
commita537231b226280bc1e5b7f0f58707cbd2cf29848 (patch)
treeeb1859f98e026156e557137750c48b20629d408a /src/gallium/meson.build
parent5060c51b6f4dfb0d5358bde6523285163d3faaad (diff)
meson: build svga driver on linux
Build tested only. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index cfb784c523d..6fe7f15da03 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -81,6 +81,10 @@ if with_gallium_i915
subdir('winsys/i915/drm')
subdir('drivers/i915')
endif
+if with_gallium_svga
+ subdir('drivers/svga')
+ subdir('winsys/svga/drm')
+endif
if with_dri
subdir('state_trackers/dri')
endif
@@ -91,7 +95,6 @@ if with_glx == 'gallium-xlib'
subdir('winsys/sw/xlib')
subdir('state_trackers/glx/xlib')
endif
-# TODO: SVGA
# TODO: SWR
# TODO: virgl
# TODO: clover