summaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-15 10:43:20 -0800
committerDylan Baker <[email protected]>2017-12-04 14:35:36 -0800
commit0bbecc5a8548883f76a7147ac7879f05a01770dc (patch)
tree1cc27fafd7566515e33ae4f6b63a4224b16ef436 /src/gallium/meson.build
parent831d2fb01260016d5c253ab516ad7a2b844bb249 (diff)
meson: define driver dependencies
This allow us to encapsulate the compiler and linkage requirements of each driver in a reusable way. The result will be that each target that needs a specific driver can simply add `driver_<name>` to its dependencies line and the necessary libraries and compiler args will be added. This will allow for a lot of code de-duplication between gallium targets. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index 4aa10826204..7ef1ffcdf06 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -37,59 +37,87 @@ if with_gallium_softpipe
if with_llvm
subdir('drivers/llvmpipe')
endif
+else
+ driver_swrast = declare_dependency()
endif
if with_gallium_r300 or with_gallium_radeonsi or with_gallium_r600
subdir('winsys/radeon/drm')
endif
if with_gallium_r300
subdir('drivers/r300')
+else
+ driver_r300 = declare_dependency()
endif
if with_gallium_r600
subdir('drivers/r600')
+else
+ driver_r600 = declare_dependency()
endif
if with_gallium_radeonsi
subdir('winsys/amdgpu/drm')
subdir('drivers/radeon')
subdir('drivers/radeonsi')
+else
+ driver_radeonsi = declare_dependency()
endif
if with_gallium_nouveau
subdir('winsys/nouveau/drm')
subdir('drivers/nouveau')
+else
+ driver_nouveau = declare_dependency()
endif
if with_gallium_freedreno
subdir('winsys/freedreno/drm')
subdir('drivers/freedreno')
+else
+ driver_freedreno = declare_dependency()
endif
if with_gallium_pl111
subdir('winsys/pl111/drm')
+else
+ driver_pl111 = declare_dependency()
endif
if with_gallium_vc4
subdir('winsys/vc4/drm')
subdir('drivers/vc4')
+else
+ driver_vc4 = declare_dependency()
endif
if with_gallium_vc5
subdir('winsys/vc5/drm')
subdir('drivers/vc5')
+else
+ driver_vc5 = declare_dependency()
endif
if with_gallium_etnaviv
subdir('winsys/etnaviv/drm')
subdir('drivers/etnaviv')
+else
+ driver_etnaviv = declare_dependency()
endif
if with_gallium_imx
subdir('winsys/imx/drm')
+else
+ driver_imx = declare_dependency()
endif
if with_gallium_i915
subdir('winsys/i915/drm')
subdir('drivers/i915')
+else
+ driver_i915 = declare_dependency()
endif
if with_gallium_svga
subdir('winsys/svga/drm')
subdir('drivers/svga')
+else
+ driver_svga = declare_dependency()
endif
if with_gallium_virgl
subdir('winsys/virgl/drm')
subdir('winsys/virgl/vtest')
subdir('drivers/virgl')
+else
+ driver_virgl = declare_dependency()
endif
# TODO: SWR
# TODO: clover