aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-24 15:52:57 -0700
committerDylan Baker <[email protected]>2017-10-27 11:06:45 -0700
commitf121a669c7d94d2ff6721e01bec72589fd081ab3 (patch)
tree419549096edb13c6afe20c600cb7005e24d5fd17 /src/gallium/meson.build
parentcbbd5bb889a2c271a504c379f36a7cb717a85af4 (diff)
meson: build gallium based osmesa
This has been tested with the osdemo from mesa-demos v2: - Add SELinux dependency - fix typo GALLIUM_LLVM -> GALLIUM_LLVMPIPE Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index e0941103b93..6edfe80321d 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -66,6 +66,9 @@ if with_gallium_imx
subdir('winsys/imx/drm')
endif
subdir('state_trackers/dri')
+if with_osmesa == 'gallium'
+ subdir('state_trackers/osmesa')
+endif
# TODO: i915
# TODO: SVGA
# TODO: r300
@@ -77,9 +80,11 @@ subdir('state_trackers/dri')
if with_dri and with_gallium
subdir('targets/dri')
endif
+if with_osmesa == 'gallium'
+ subdir('targets/osmesa')
+endif
# TODO: xlib-glx
# TODO: OMX
-# TODO: osmesa
# TODO: VA
# TODO: vdpau
# TODO: xa