summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/virgl/tests/meson.build
diff options
context:
space:
mode:
authorAlexandros Frantzis <[email protected]>2019-06-25 13:56:52 +0300
committerChia-I Wu <[email protected]>2019-06-28 04:30:02 +0000
commit790d1a0b17376ac3c53c123f7a1b117220d71f95 (patch)
tree7360fa6d492332abd4fa3f7c32fac299d6ea9fb1 /src/gallium/drivers/virgl/tests/meson.build
parent55a58dfcfbf3bf39c61ffd31401e513648262275 (diff)
virgl: Add tests for virgl_staging_mgr
Signed-off-by: Alexandros Frantzis <[email protected]> Reviewed-by: Chia-I Wu <[email protected]>
Diffstat (limited to 'src/gallium/drivers/virgl/tests/meson.build')
-rw-r--r--src/gallium/drivers/virgl/tests/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/gallium/drivers/virgl/tests/meson.build b/src/gallium/drivers/virgl/tests/meson.build
new file mode 100644
index 00000000000..86cb27db4e1
--- /dev/null
+++ b/src/gallium/drivers/virgl/tests/meson.build
@@ -0,0 +1,31 @@
+# Copyright © 2019 Collabora Ltd.
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+test(
+ 'virgl_staging_mgr',
+ executable(
+ 'virgl_staging_mgr_test',
+ files('virgl_staging_mgr_test.cpp'),
+ dependencies : [dep_thread, idep_gtest],
+ include_directories : [inc_common, include_directories('..')],
+ link_with : [libvirgl, libgallium],
+ ),
+ suite : ['virgl'],
+)