summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/vc5/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2017-12-28 14:00:15 -0800
committerEric Anholt <[email protected]>2018-01-12 21:53:26 -0800
commit954a704da3052028da4129cc7757f5f224ee1ffc (patch)
treecedeb2a2cd22764b5b1cf9f54a545469f9287d52 /src/gallium/drivers/vc5/meson.build
parent80c84241af9fbb1e23fe630c5d4fd6d266a74060 (diff)
broadcom/vc5: Port the RCL setup to V3D4.1.
The TLB load/store path is rebuilt in this version. There is no longer a single-byte resolved store or the 3-byte extended store. Instead, you get to always use general loads/stores (which, honestly, was tempting even in previous versions).
Diffstat (limited to 'src/gallium/drivers/vc5/meson.build')
-rw-r--r--src/gallium/drivers/vc5/meson.build24
1 files changed, 23 insertions, 1 deletions
diff --git a/src/gallium/drivers/vc5/meson.build b/src/gallium/drivers/vc5/meson.build
index deaa81fdb9d..ad4395212b2 100644
--- a/src/gallium/drivers/vc5/meson.build
+++ b/src/gallium/drivers/vc5/meson.build
@@ -33,7 +33,6 @@ files_libvc5 = files(
'vc5_job.c',
'vc5_program.c',
'vc5_query.c',
- 'vc5_rcl.c',
'vc5_resource.c',
'vc5_resource.h',
'vc5_screen.c',
@@ -46,12 +45,34 @@ files_libvc5 = files(
'vc5_uniforms.c',
)
+files_per_version = files(
+ 'vc5_rcl.c',
+)
+
v3dv3_c_args = []
dep_v3dv3 = dependency('v3dv3')
if dep_v3dv3.found()
v3dv3_c_args = '-DUSE_VC5_SIMULATOR'
endif
+vc5_versions = ['33', '41']
+
+per_version_libs = []
+foreach ver : vc5_versions
+ per_version_libs += static_library(
+ 'vc5-v' + ver,
+ [files_per_version, v3d_xml_pack, nir_opcodes_h, nir_builder_opcodes_h],
+ include_directories : [
+ inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_broadcom,
+ inc_gallium_drivers, inc_drm_uapi,
+ ],
+ c_args : [c_vis_args, v3dv3_c_args, '-DV3D_VERSION=' + ver],
+ cpp_args : [cpp_vis_args],
+ dependencies : [dep_v3dv3, dep_libdrm, dep_valgrind],
+)
+
+endforeach
+
libvc5 = static_library(
'vc5',
[files_libvc5, v3d_xml_pack],
@@ -62,6 +83,7 @@ libvc5 = static_library(
c_args : [c_vis_args, v3dv3_c_args],
cpp_args : [cpp_vis_args, v3dv3_c_args],
dependencies : [dep_v3dv3, dep_libdrm, dep_valgrind, idep_nir_headers],
+ link_with: per_version_libs,
)
driver_vc5 = declare_dependency(